Skip to main content
← All vulnerabilities
CVE-2026-54049GHSA-W2X5-GV52-9CCV

Sakai Conversations has a Stored XSS Issue

Published
Last modified
published
Not listed in CISA KEV
Fix
Fixed in 23.5, 25.3
None on Exploit-DB, Metasploit or GitHub
  • Exploitation: poc
  • Automatable: no
  • Technical impact: total

Summary

Sakai is a Collaboration and Learning Environment (CLE). From versions 23.0 to before 23.5, and versions 25.0 to before 25.3, the Sakai Conversations tool stores topic and post messages without HTML sanitization, and the frontend renders them using LitElement's unsafeHTML() directive, resulting in stored cross-site scripting (XSS). Any authenticated user with access to a site that has the Conversations tool enabled can inject arbitrary HTML and JavaScript that executes in the browsers of all other users who view that topic or post. This issue has been patched in versions 23.5, 25.3, and 26.0.

Timeline

  1. CVE published
  2. CISA SSVC assessment

    Exploitation: poc · Automatable: no · Technical impact: total

  3. Record last updated

Affected versions

  • sakaiproject sakai

    From 23.0 · fixed in 23.5; From 25.0 · fixed in 25.3

  • org.sakaiproject.conversations:sakai-conversations-implMaven

    From 23.0 · through 23.3

  • org.sakaiproject.kernel:sakai-kernel-implMaven

    From 23.0 · through 23.3

  • org.sakaiproject.rubrics:rubrics-implMaven

    From 23.0 · through 23.3

References 2

GitHub · sakaiproject/sakai