Skip to main content
← All vulnerabilities
CVE-2026-5139GO-2026-6480GHSA-2G8V-GRQ3-HQ2G

GitLab Plugin Allows Non-Admin Users to Modify Default Instance Configuration

Published
Last modified
published
Not listed in CISA KEV
Fix
Fixed in 10.11.18+incompatible, 11.5.6+incompatible, 11.6.3+incompatible, 11.7.1+incompatible, 11.7.1, and 3 more
None on Exploit-DB, Metasploit or GitHub
  • Exploitation: none
  • Automatable: no
  • Technical impact: partial

Summary

Mattermost versions 11.7.x <= 11.7.0, 11.6.x <= 11.6.2, 11.5.x <= 11.5.5, 10.11.x <= 10.11.17 fail to enforce administrator authorization on the {{setDefaultInstance}} call within the {{/gitlab connect}} command handler, which allows any authenticated user to overwrite the global default GitLab instance configuration via the {{/gitlab connect <instance-name>}} slash command.. Mattermost Advisory ID: MMSA-2026-00644

Timeline

  1. CVE published
  2. CISA SSVC assessment

    Exploitation: none · Automatable: no · Technical impact: partial

  3. Record last updated

Affected versions

  • Mattermost Mattermost

    From 11.7.0 · through 11.7.0; From 11.6.0 · through 11.6.2; From 11.5.0 · through 11.5.5; From 10.11.0 · through 10.11.17

  • github.com/mattermost/mattermost-serverGo

    From 10.11.0+incompatible · fixed in 10.11.18+incompatible; From 11.5.0+incompatible · fixed in 11.5.6+incompatible; From 11.6.0+incompatible · fixed in 11.6.3+incompatible; From 11.7.0+incompatible · fixed in 11.7.1+incompatible

  • github.com/mattermost/mattermost-serverGo

    From 11.7.0 · fixed in 11.7.1

  • github.com/mattermost/mattermost-serverGo

    From 11.6.0 · fixed in 11.6.3

  • github.com/mattermost/mattermost-serverGo

    From 11.5.0 · fixed in 11.5.6

  • github.com/mattermost/mattermost-serverGo

    From 10.11.0 · fixed in 10.11.18

References 1

mattermost.com