Skip to main content
← All vulnerabilities
CVE-2026-5079GHSA-72GW-MP4G-V24J

multer vulnerable to Denial of Service via deeply nested field names

Published
Last modified
published
Not listed in CISA KEV
Fix
Fixed in 2.2.0, 3.0.0-alpha.2
None on Exploit-DB, Metasploit or GitHub
  • Exploitation: none
  • Automatable: yes
  • Technical impact: partial

Summary

Impact: multer versions 1.0.0 through 2.1.1 and 3.0.0-alpha.1 are vulnerable to a Denial of Service via deeply nested field names in multipart form data. The append-field dependency parses bracket notation in field names with no limit on nesting depth, allowing an attacker to force allocation of deeply nested object structures that consume CPU and memory. A single HTTP request with a crafted multipart body is sufficient to exploit this. Patches: Users should upgrade to multer 2.2.0 (2.x line) or 3.0.0-alpha.2 (3.x prerelease) and configure the new limits.fieldNestingDepth option to the minimum depth their application requires. Workarounds: Set limits.fields to a reasonable value to reduce the number of fields an attacker can send per request. This does not fully mitigate the issue but limits the impact.

Timeline

  1. CVE published
  2. CISA SSVC assessment

    Exploitation: none · Automatable: yes · Technical impact: partial

  3. Record last updated

Affected versions

  • multer multer

    From 1.0.0 · fixed in 2.2.0; From 3.0.0-alpha.1 · fixed in 3.0.0-alpha.2

  • multernpm

    From 1.0.0 · fixed in 2.2.0

  • multernpm

    From 3.0.0-alpha.1 · fixed in 3.0.0-alpha.2

References 2

GitHub · expressjs/multer

cna.openjsf.org