CVE-2026-49042GHSA-HH8R-75R6-QRG9
Apache Camel: langchain4j-tools: filter tool argument headers against declared parameters
- Published
- Last modified
- Where the record stands: published, rejected by its publisher, or superseded by another id.What do these mean? →
- published
- Whether CISA lists it in its Known Exploited Vulnerabilities catalog: proof that attackers are using it.What do these mean? →
- Not listed in CISA KEV
- Fix
- Fixed in 4.18.3, 4.21.0
- Whether working attack code is public (Exploit-DB, Metasploit, Nuclei or GitHub). Public code makes attacks easier.What do these mean? →
- 1 proof of concept on GitHub
CISA's decision points: whether it is exploited, whether attacks can be automated, and how much control an attacker gets. Assessed (SSVC 2.0.3).What do these mean? →
- Exploitation: none
- Automatable: yes
- Technical impact: partial
Summary
Improper Input Validation vulnerability in Apache Camel. This issue affects Apache Camel: from 4.8.0 through 4.18.2, from 4.19.0 through 4.20.0. Users are recommended to upgrade to version 4.18.3, 4.21.0, which fixes the issue.
Timeline
- CVE published
- CISA SSVC assessment
Exploitation: none · Automatable: yes · Technical impact: partial
- Record last updated
Affected versions
- Apache Software Foundation Apache Camel
From 4.8.0 · through 4.18.2; From 4.19.0 · through 4.20.0
- org.apache.camel:camel-langchain4j-toolsMaven
From 4.8.0 · fixed in 4.18.3
- org.apache.camel:camel-langchain4j-toolsMaven
From 4.19.0 · fixed in 4.21.0
- org.apache.camel:camel-langchain4j-agentMaven
From 4.8.0 · fixed in 4.18.3
- org.apache.camel:camel-langchain4j-agentMaven
From 4.19.0 · fixed in 4.21.0
- org.apache.camel:camel-spring-ai-toolsMaven
From 4.8.0 · fixed in 4.18.3
- org.apache.camel:camel-spring-ai-toolsMaven
From 4.19.0 · fixed in 4.21.0